cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
FrankvH
Level 6

R2019R2 Archived device gets reporting again

Hello,

In our environment we came across the problem that a device was archived for a long time. But we have seen that the device is reporting again but the status doesnt change to active. We can see that the device is updated in the history TAB and we see that the server contains fresh IBM peak counts.

So questions:

  • Why is this server not set to active?
  • How can find which server is in this situation? Without looking in each history tab.
  • How can change the status to active?

Thanks for your help!!

Frank

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

3 Replies
Kevin_Hou
Flexera Alumni

Hello @FrankvH 

I am wondering how did you notice this archive device start reporting again? I assume you are seeing the 'inventory date' got updated daily? 

Pier to the online help -- https://docs.flexera.com/FlexNetManagerSuite2019R2/EN/WebHelp/index.html#topics/Dev-Archived_Inventory.html

"Tip: If an inventory device that is Archived is unexpectedly matched in incoming inventory — that is, the device somehow reappears — then its status is automatically switched from Archived back to Active, and it disappears from this listing and is once again available in the All Inventory page. Most of the time, though, a device disappears from this listing because it has finally been deleted."

Hence what you are seeing seem odd, I will suggest opening a support ticket to your local support team for further investigation.

For something quick, and if you are an on premise customer , you could try update this ComplianceComputer status from archive to active via a sql statement and closely monitor afterwards. If you are an cloud solution FNMS user, the 'status' switch is supposed to be done by the system automatically. So please no hesitate and reaching out our support team if is necessary.

 

Cheers

(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".)

Hi Kevin,

Thanks for your reply and link. I already opened a case but was wondering if other people have the same problem.

I have noticed this issue because an archived device start getting new IBM peak usage and when I looked in the device itself I saw that the history was update recently.

So currently I have 2 issues:

  • How do I get this device back to active as this is not happening automatically
  • And how do I know which devices are in this status I cant look in each history.

Regards

Frank

 

0 Kudos

Hi @FrankvH 

At this stage, to revert an 'archived' device to 'active', I am afraid you will need to use SQL update statement, something like below for a On Premise solution customer.

UPDATE ComplianceComputer
SET ComplianceComputerStatusID = 1
WHERE ComputerName = 'ChangeToMachineName' and ComplianceComputerStatusID = 6

For Cloud FNMS, you will need to work with support to update the status. As UI doesn't give the user certain control/'button' to switch the Status at the moment. 

I will still suggest checking more fundamentally such as the "Last Inventory Date" field when you open the "general tab" of this machine, does this machine has quite recent date there? if so you may try to understand why the inventory tool is still reporting daily inventory back but status is in an 'archived' status  ? Will any chance could be a manual 'deletion' from UI by an operator operation causing that?  (you may check from History tab and map the timestampe/username to give some further understanding why the machine was updated to 'archived' ?

 

Cheers

 

(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".)