Some users may have issues creating a community account. For more information, please click here.

KarolinaWilk1
Occasional contributor

Failure when upgrading to FNMS on prem 2021 r1

Jump to solution

Hi Team

 

When upgrading FNMS on premise from 2020 r2 to 2021 r1 while executing ComplianceMigration.xml for FNMSCompliance after 1 hour of processing I received following error and the update for db failed.

Can you please help me and confirm if I can remove the said in the error index and column which cause the failure as indeed I found them in our FNMSCompliance db.

 

The error is:

Preparing to run step 'Check migrated schema against expected'.
Required minimum database compatibility level: SQL Server 2008 (100)
Found database compatibility level: SQL Server 2012 (110)
Required version: 17.0
Found version: 17.0
Executing step
Checking that all database objects are owned by dbo...Validated
Running 'ComplianceSchema_schemacheck.sql'.

Returned row: MigrationErrors: Extra column: SoftwareRecognition.SoftwareLicensePointsRuleSoftwareTitleID
Returned row: MigrationErrors: Extra Index: SoftwareRecognition.IX_SoftwareRecognition_TypeOfID_SoftwareLicensePointsRuleSoftwareTitleID_SoftwareRecognitionID


There was an error while attempting to run 'ComplianceSchema_schemacheck.sql'.
Returned row count 2 does not equal expected row count 0

 

BR, Karolina

Labels (1)
1 Solution

This issue was caused by a change in the ARL (version 2622) that was released last week. The FNMS upgrade would still have completed. The next ARL version which is going to be released this week would address the issue and upgrades should no longer give this error.

View solution in original post

8 Replies
ChrisG
Community Manager Community Manager
Community Manager

This type of failure doesn't appear to have been reported previously, but I know you've raised a case with Flexera Support who will be able to work through it with you.

If you get a chance, please post back here once you've been able to get past the problem to help others who may encounter the same thing.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos
SenthilNathan
Active participant

I bumped into the same issue while upgrading FNMS 2019 R2 to 2020 R2.   

FNMS_DB_Upgrade_Error.JPG

0 Kudos

HI

 

You might be using some customization. Which creates extra column. Now you need to modify schema & add that extra one & rerun.

0 Kudos

This issue was caused by a change in the ARL (version 2622) that was released last week. The FNMS upgrade would still have completed. The next ARL version which is going to be released this week would address the issue and upgrades should no longer give this error.

View solution in original post

@sunilkumar: To be sure and clear my confusion, as you mentioned "The FNMS upgrade would still have completed. The next ARL version which is going to be released this week would address the issue and upgrades should no longer give this error."

  1. Even though the FNMS DB upgrade shows an error, it would have been completed successfully?
  2. Can I continue on the Inventory & DataWarehouse DB upgrade?
  3. Or do need to wait until next week for the new ARL version to be released to fix this issue?
0 Kudos
Reach out to Flexera Consultant, they will provide you a file to be replaced in the binary package, so you can continue on the upgrade and it will be finished successfully. Good luck!
0 Kudos

@SenthilNathan , The upgrade would have completed and at the end of the migration, a schema check is performed which failed. However, as ARL version 2624 which has the fix will be available by Monday (16th August), I would recommend that you import this ARL and run the migration scripts again. It should go through without any errors. You can then continue with point 2 in your note above.

@sunilkumar:  thanks for the confirmation.

0 Kudos