Showing results for 
Show  only  | Search instead for 
Did you mean: 

Inventroy agent upgrade failure with ndtrack.exe missing.

We are facing issues with upgrading our flexera agent.

We are currently using the Flexnet Manager Suite 2022 R1 and the flexnet inventory agent is 18.00.452

I am trying to upgrade the flexnet inventory agent to 21.0.0

Please find the attached screenshot of failure.

Kindly help me with prefferd upgrade approach in this case.

(6) Replies

Maybe the agent file you downloaded was somehow corrupted?  Have you tried to download the agent installer again and retry the installation?


Dear Mark, 

This is happening only with the 2023 R2 agent, When i tried the 2023 R1 Agent it worked fine. 

I feel like the file getting downloaded itself is corrupted.

By Community Manager Community Manager
Community Manager

What do you see in the file if you open it? You should see a set of files including the following:


(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

it is there

Stupid questions but: have you tried to download the agent one more time and are you installing as administrator?

We have identified the installation is getting prevented by kaspersky, but when we tried the 2022 R2 version it is working fine.