Highlighted
Active participant

Inventory Agent Configuration to Point to Beacon DNS rather than FQDN

Jump to solution

Hi,

 

I have a scenario where FQDN and the DNS name is different for beacon. We are using DNS and the communication between agents , beacon and app server is on SSL.

 

I did change mgssetup.ini and point it to my beacon DNS. Policy download works fine, but upload fails from agent to beacon as in registery under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ManageSoft Corp\ManageSoft\Common\UploadSettings\{611F1577-A91E-43DD-XXXXXX} Host registry points to FQDN, same goes for DownloadSettings. I did change manually but then when I restart the service it change it back to FQDN. Which cause agent communication issues.

 

Thanks and Regards,

FL

Thanks & Regards,
Fawad Laiq
0 Kudos
2 Solutions

Accepted Solutions
Highlighted
Flexera
Flexera

Re: Inventory Agent Configuration to Point to Beacon DNS rather than FQDN

Jump to solution
@fawad_laiq,

Correct - setting the NetworkName within the BeaconEngine.config will mean that all agents reporting to this beacon will be forced to use this new 'override' value.

A suggestion for next steps, with the limited context that I have so far:

1) Revert whatever changes you made to the Default Failover Settings
2) Take a backup of the current BeaconEngine.config
3) Amend the 'NetworkName' within the BeaconEngine.config to the correct DNS name + save the file
4) Restart the Beacon Engine service

If you run into further difficulties, I'd suggest opening a support case so that one of us can help you investigate further.

HTH,
Joseph
If my response answered your question satisfactorily, please click "ACCEPT AS SOLUTION" to heighten visibility for future customers!

View solution in original post

Highlighted
Frequent contributor

Re: Inventory Agent Configuration to Point to Beacon DNS rather than FQDN

Jump to solution

Hi Fawad & JJensen,

Actually, the 'BeaconEngine.config' file in the \Program Files (x86)\Flexera Software\Inventory Beacon\DotNet\conf folder on your Beacon is being created and may be overwritten based on the content of the [FNMSCompliance].[Beacon_MT] table.Editing this file manually might result in a little frustration.

If you check the contents of the [HTTPAccessData] text column for your Beacon, you should see a XML snippet that looks like:

<?xml version="1.0" encoding="utf-16"?>
<HTTPEndPointStatus xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <DownloadPath>ManageSoftDL</DownloadPath>
   <UploadPath>ManageSoftRL</UploadPath>
   <Protocol>https</Protocol>
   <Port>443</Port>
   <SelfHosted>false</SelfHosted>
   <CredentialsRequired>false</CredentialsRequired>
   <NetworkName><your-beacon-FQDN></NetworkName>
</HTTPEndPointStatus>

Obviously, you can customize the text between <NetworkName></NetworkName> to use the correct Beacon DNS name.

Then:

  • Trigger creation of a new policy, for example by changing some minor setting under "Discovery & Inventory > Settings" and hit save
  • Stop and re-start the "FlexNet Beacon Engine" Windows Service on your Beacon to trigger the download of the latest configuration file.

You should see that the 'BeaconEngine.config' as well as the .ndc file for failover settings on your Beacon(s) are being updated.

View solution in original post

11 Replies
Highlighted
Flexera
Flexera

Re: Inventory Agent Configuration to Point to Beacon DNS rather than FQDN

Jump to solution
Hello Fawad,

The below Online Help article may be of some use, specifically 'NetworkName':

https://helpnet.flexerasoftware.com/fnms/EN/WebHelp/index.html#reference/FIB-WebConfigFile.html

Manual changes to the UploadSettings/DownloadSettings registry keys will be overwritten during the next agent policy update.



If my response answered your question satisfactorily, please click "ACCEPT AS SOLUTION" to heighten visibility for future customers!
Highlighted
Active participant

Re: Inventory Agent Configuration to Point to Beacon DNS rather than FQDN

Jump to solution

Hi @jjensen 

 

Thanks for the quick response. So that means if I change this value over there this would automatically change the host name on my agents when they would retrieve the policy next time? 

 

As I can see in ProgramData\Flexera Software\Staging\Common\ClientSettings\Default Failover Settings, there it is still pointing to FQDN name which I can see at agent in Program Files (x86)\ManageSoft\Launcher\Cache\Common\ManagedDeviceSettings file contents.ndc which seems same like registry still points to FQDN. 

I tried changing settings in Default failover then my agent stopped downloaing the machine policy.

 

Thanks and Regards,

FL

Thanks & Regards,
Fawad Laiq
0 Kudos
Highlighted
Flexera
Flexera

Re: Inventory Agent Configuration to Point to Beacon DNS rather than FQDN

Jump to solution
@fawad_laiq,

Correct - setting the NetworkName within the BeaconEngine.config will mean that all agents reporting to this beacon will be forced to use this new 'override' value.

A suggestion for next steps, with the limited context that I have so far:

1) Revert whatever changes you made to the Default Failover Settings
2) Take a backup of the current BeaconEngine.config
3) Amend the 'NetworkName' within the BeaconEngine.config to the correct DNS name + save the file
4) Restart the Beacon Engine service

If you run into further difficulties, I'd suggest opening a support case so that one of us can help you investigate further.

HTH,
Joseph
If my response answered your question satisfactorily, please click "ACCEPT AS SOLUTION" to heighten visibility for future customers!

View solution in original post

Highlighted
Frequent contributor

Re: Inventory Agent Configuration to Point to Beacon DNS rather than FQDN

Jump to solution

Hi Fawad & JJensen,

Actually, the 'BeaconEngine.config' file in the \Program Files (x86)\Flexera Software\Inventory Beacon\DotNet\conf folder on your Beacon is being created and may be overwritten based on the content of the [FNMSCompliance].[Beacon_MT] table.Editing this file manually might result in a little frustration.

If you check the contents of the [HTTPAccessData] text column for your Beacon, you should see a XML snippet that looks like:

<?xml version="1.0" encoding="utf-16"?>
<HTTPEndPointStatus xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <DownloadPath>ManageSoftDL</DownloadPath>
   <UploadPath>ManageSoftRL</UploadPath>
   <Protocol>https</Protocol>
   <Port>443</Port>
   <SelfHosted>false</SelfHosted>
   <CredentialsRequired>false</CredentialsRequired>
   <NetworkName><your-beacon-FQDN></NetworkName>
</HTTPEndPointStatus>

Obviously, you can customize the text between <NetworkName></NetworkName> to use the correct Beacon DNS name.

Then:

  • Trigger creation of a new policy, for example by changing some minor setting under "Discovery & Inventory > Settings" and hit save
  • Stop and re-start the "FlexNet Beacon Engine" Windows Service on your Beacon to trigger the download of the latest configuration file.

You should see that the 'BeaconEngine.config' as well as the .ndc file for failover settings on your Beacon(s) are being updated.

View solution in original post