fawad_laiq
Level 5

Inventory Agent Configuration to Point to Beacon DNS rather than FQDN

Jump to solution

Hi,

 

I have a scenario where FQDN and the DNS name is different for beacon. We are using DNS and the communication between agents , beacon and app server is on SSL.

 

I did change mgssetup.ini and point it to my beacon DNS. Policy download works fine, but upload fails from agent to beacon as in registery under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ManageSoft Corp\ManageSoft\Common\UploadSettings\{611F1577-A91E-43DD-XXXXXX} Host registry points to FQDN, same goes for DownloadSettings. I did change manually but then when I restart the service it change it back to FQDN. Which cause agent communication issues.

 

Thanks and Regards,

FL

Thanks & Regards,
Fawad Laiq
0 Kudos
2 Solutions
@fawad_laiq,

Correct - setting the NetworkName within the BeaconEngine.config will mean that all agents reporting to this beacon will be forced to use this new 'override' value.

A suggestion for next steps, with the limited context that I have so far:

1) Revert whatever changes you made to the Default Failover Settings
2) Take a backup of the current BeaconEngine.config
3) Amend the 'NetworkName' within the BeaconEngine.config to the correct DNS name + save the file
4) Restart the Beacon Engine service

If you run into further difficulties, I'd suggest opening a support case so that one of us can help you investigate further.

HTH,
Joseph
If my response answered your question satisfactorily, please click "ACCEPT AS SOLUTION" to heighten visibility for future customers!

View solution in original post

Hi Fawad & JJensen,

Actually, the 'BeaconEngine.config' file in the \Program Files (x86)\Flexera Software\Inventory Beacon\DotNet\conf folder on your Beacon is being created and may be overwritten based on the content of the [FNMSCompliance].[Beacon_MT] table.Editing this file manually might result in a little frustration.

If you check the contents of the [HTTPAccessData] text column for your Beacon, you should see a XML snippet that looks like:

<?xml version="1.0" encoding="utf-16"?>
<HTTPEndPointStatus xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <DownloadPath>ManageSoftDL</DownloadPath>
   <UploadPath>ManageSoftRL</UploadPath>
   <Protocol>https</Protocol>
   <Port>443</Port>
   <SelfHosted>false</SelfHosted>
   <CredentialsRequired>false</CredentialsRequired>
   <NetworkName><your-beacon-FQDN></NetworkName>
</HTTPEndPointStatus>

Obviously, you can customize the text between <NetworkName></NetworkName> to use the correct Beacon DNS name.

Then:

  • Trigger creation of a new policy, for example by changing some minor setting under "Discovery & Inventory > Settings" and hit save
  • Stop and re-start the "FlexNet Beacon Engine" Windows Service on your Beacon to trigger the download of the latest configuration file.

You should see that the 'BeaconEngine.config' as well as the .ndc file for failover settings on your Beacon(s) are being updated.

View solution in original post

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

11 Replies
jjensen
Flexera Alumni
Hello Fawad,

The below Online Help article may be of some use, specifically 'NetworkName':

https://helpnet.flexerasoftware.com/fnms/EN/WebHelp/index.html#reference/FIB-WebConfigFile.html

Manual changes to the UploadSettings/DownloadSettings registry keys will be overwritten during the next agent policy update.



If my response answered your question satisfactorily, please click "ACCEPT AS SOLUTION" to heighten visibility for future customers!

Hi @jjensen 

 

Thanks for the quick response. So that means if I change this value over there this would automatically change the host name on my agents when they would retrieve the policy next time? 

 

As I can see in ProgramData\Flexera Software\Staging\Common\ClientSettings\Default Failover Settings, there it is still pointing to FQDN name which I can see at agent in Program Files (x86)\ManageSoft\Launcher\Cache\Common\ManagedDeviceSettings file contents.ndc which seems same like registry still points to FQDN. 

I tried changing settings in Default failover then my agent stopped downloaing the machine policy.

 

Thanks and Regards,

FL

Thanks & Regards,
Fawad Laiq
0 Kudos
@fawad_laiq,

Correct - setting the NetworkName within the BeaconEngine.config will mean that all agents reporting to this beacon will be forced to use this new 'override' value.

A suggestion for next steps, with the limited context that I have so far:

1) Revert whatever changes you made to the Default Failover Settings
2) Take a backup of the current BeaconEngine.config
3) Amend the 'NetworkName' within the BeaconEngine.config to the correct DNS name + save the file
4) Restart the Beacon Engine service

If you run into further difficulties, I'd suggest opening a support case so that one of us can help you investigate further.

HTH,
Joseph
If my response answered your question satisfactorily, please click "ACCEPT AS SOLUTION" to heighten visibility for future customers!

Hi Fawad & JJensen,

Actually, the 'BeaconEngine.config' file in the \Program Files (x86)\Flexera Software\Inventory Beacon\DotNet\conf folder on your Beacon is being created and may be overwritten based on the content of the [FNMSCompliance].[Beacon_MT] table.Editing this file manually might result in a little frustration.

If you check the contents of the [HTTPAccessData] text column for your Beacon, you should see a XML snippet that looks like:

<?xml version="1.0" encoding="utf-16"?>
<HTTPEndPointStatus xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <DownloadPath>ManageSoftDL</DownloadPath>
   <UploadPath>ManageSoftRL</UploadPath>
   <Protocol>https</Protocol>
   <Port>443</Port>
   <SelfHosted>false</SelfHosted>
   <CredentialsRequired>false</CredentialsRequired>
   <NetworkName><your-beacon-FQDN></NetworkName>
</HTTPEndPointStatus>

Obviously, you can customize the text between <NetworkName></NetworkName> to use the correct Beacon DNS name.

Then:

  • Trigger creation of a new policy, for example by changing some minor setting under "Discovery & Inventory > Settings" and hit save
  • Stop and re-start the "FlexNet Beacon Engine" Windows Service on your Beacon to trigger the download of the latest configuration file.

You should see that the 'BeaconEngine.config' as well as the .ndc file for failover settings on your Beacon(s) are being updated.

Hi,

Thanks a lot for your explanation. Could you also guide me abput below two points:

* which file are we referring to for this xml, please if you could provide location and file name.
* If we would like to have failover of beacon also.
* and if we need to change reporting beacon later, as this is devopment and later we would need to point agents to Production server.


Thanks in advance.

Thanks & Regards,
Fawad Laiq


$3nt fr0m h@ndh3ld, e>
Thanks & Regards,
Fawad Laiq
0 Kudos

Hi Fawad,

This is not an XML file. The configuration information is stored as text in the [HTTPAccessData] column in the [FNMSCompliance].[Beacon_MT] table.

There is one row per Beacon in this table. Obviously, you need access to the SQL Server database for updating these data.

All Beacons in your environment are configured as "Fail-over Beacons" by default.

In case you want to update an existing Beacon and point it to a different FNMS environment, follow these steps:

  • In the old (testing) FNMS environment, delete the Beacon from the FNMS Web UI
  • Create a new Beacon in the Web UI of the new (production) FNMS environment using the "Configure a Beacon" button.
  • Give the Beacon a name and generate a new unique ID for the Beacon
  • Download the new Beacon XML configuration file from the production FNMS environment to the existing Beacon
  • Update the old BeaconUID value in the Windows Registry on the existing Beacon in the HKLM > Software > WOW6432Node > ManageSoft Corp > ManageSoft > Common branch to match the new BeaconUID value. Leave the curly brackets {} around the BeaconUID value.
  • Import the new XML config file into the existing Beacon

After completing and saving your configuration on the Beacon, your Beacon should start communicating with the new FNMS environment.

 

0 Kudos

Hi @erwinlindemann 

Moreover Fail-over Beacons setting still shows FQDN. Please help me as you wrote manually changing might be a little frustration.  Seems like I am missing something here.

 

Thanks & Regards,
Fawad Laiq
0 Kudos

Hi Fawad,

Updating the contents in the [FNMSCompliance].[Beacon_MT].[HTTPAccessData] column in the SQL Server database to contain the correct DNS name between the <NetworkName></NetworkName> tags followed by enforcing a refresh of the Policy and the "BeaconPolicy.xml" files on the Beacon as recommended previously should solve the problem.

The Beacon configuration - including the "NetworkName" property of the Beacon - will typically be downloaded from the FNMS Inventory Server to all Beacons in the "BeaconPolicy.xml" configuration file. This file is generated dynamically and will be downloaded to the following folder on the Beacon(s): \ProgramData\Flexera Software\Beacon. You can check this file for the correct DNS name of your Beacon(s).

Flexera agents will download selected data from the "BeaconPolicy.xml" - aka: the "Policy" - on a daily basis.

To speed this up, you can:

  • Enforce an update of the Policy by saving the configuration in the Web UI ("Discovery & Inventory > Settings") manually
  • Trigger the immediate download of the updated "BeaconPolicy.xml" to any beacon by clicking on the "Rules > Update Rules" button on the Beacon UI (this runs every 15 min by default)
  • Trigger the download of the Policy to any agent by running "mgspolicy -t machine" from a command prompt with elevated privileges on the computer running the Flexera agent (this runs daily by default)

Hi Erwin,

 

Thanks a lot for your help. I checked in BeaconEngine.config which I already changed. Now I have checked database also and it shows DNS, but agent still has FQDN.

 

Do I need to change something else as I did this change in BeaconEngine?

 

Thanks & Regards,
FL 

Thanks & Regards,
Fawad Laiq
0 Kudos
steven_donovan1
Level 6

1.Did you configure the cert to use the alias

2.You have to add the alias to edit the BeaconEngine.config file

https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/How-to-configure-the-beacon-to-use-a-different-name-or-alias/ta-p/2064

0 Kudos

Here are some notes to clarify points which were made earlier in this discussion thread which I think may not be quite correct:

  • @jjensen's initial pointer to set the networkname setting in the C:\Program Files (x86)\Flexera Software\Inventory Beacon\DotNet\conf\BeaconEngine.config file as per https://helpnet.flexerasoftware.com/fnms/EN/WebHelp/index.html#reference/FIB-WebConfigFile.html is the correct place to start here. Set networkname to the DNS name that you want agents to use when communicating with the beacon.

  • This information will be subsequently uploaded to the application server. I'm not sure of the schedule of this upload, but I've observed it can take some time. Maybe allow a day or so. Restarting the Beacon Engine service may help to speed this step along, although I'm not sure about that - it won't hurt to try. Once the information is uploaded to the application, it gets stored in the Beacon table in the compliance database that @erwinlindemann has mentioned. You should not seek to directly make changes to the contents of this table yourself; if you do make changes they are likely to be overwritten by the system at some point based on the information in the BeaconEngine.config file.

  • When each beacon in your environment updates its beacon policy, the latest beacon name information stored in the Beacon table will be downloaded as part of the policy and stored in the C:\ProgramData\Flexera Software\Beacon\BeaconPolicy.xml file mentioned earlier.

  • When each agent in your environment updates its agent policy, it will download beacon failover settings details to be stored in the registry. The beacon generates a Default Failover Settings.ndc file based on what is stored by the beacon in its BeaconPolicy.xml file. The agent downloads the .ndc file. Of course, the agent can only download this file if it is currently in a state where it can successfully communicate with a beacon. If the agent configuration has been messed up such that it cannot communicate with a beacon (e.g. because it has lost track of the beacon's DNS name), it will be orphaned until you manually do something about it.
(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)