Showing results for 
Show  only  | Search instead for 
Did you mean: 

Could not create new Corporate Units structure in FNMS using BAS

Hi Team,

We are trying to create corporate unit names using BAS however, FNMS could not seem to split into parent/child structure, instead created as 2 separate records

Ex: We are trying to create the structure "First Rand Bank Ltd/First National Bank" using BAS

however, in FNMS, it could not split, but it created as 2 separate entries in FNMS>Enterprise Groups>Corp.Units

First Rand Bank Ltd

First National Bank

Appreciate your help.

(11) Replies

@Cbrhodes  - By default, the Business Adapter uses the "/" character as a delimiter when creating Enterprise Groups.  When you supply a value of First Rand Bank Ltd/First National Bank, FlexNet Manager will create a parent/child relationship of these two values as:

First Rand Bank Ltd

     First National Bank


Is this what you are trying to accomplish?


yes, that is what we expecting.

However, the 2 records are created separately.

Note: The "split" filed is set to "/" in "data transformation" in BAS





Could you share a data sample for a test, or maybe your import xml file? But please make sure to remove sensitive data first.

Best regards,



Thanks for your quick reply

Please find the xml file, source CSV file - that we trying to import. 

Also, attached the screenshots for your quick ref. to review our steps are correct.

You urgent assistance is highly appreciated.

We never faced this issue in previous version 2017R3,we recently upgraded to fnms 2019R1

@mfranz @kclausen 

FYI please - we had issues with "comma" as delimiter earlier using BAS, so we started running BAS using schema.ini file - mentioning "semicolon"  as the delimiter. You can see in the screenshots attached earlier.

Not sure, if this is causing issue in identifying "/" as another separator and failing to create BU structure ?

Should we mention both ; and / in schema.ini ? Just a thought ? 


Hi @LorenDon 

I think you'll need to have ID enabled for CorporateUnit item in BA.

It should take a value of CorporateUnit_ID (ObjectID from Corporate Unit Item). If this Values is not available from dropdown, you can just delete the item and recreate it. ID should be enabled automatically, then just set value for Name.

I am not sure 100% why it has to be this way, but I think that is how it matches child values to parent.




Thanks for your response.

As per our knowledge, this doesn't matter for structure creation (we performed the same steps on our dev environment which is working fine as expected), however on production we have enabled "corporate unit_ID" and tested, still no luck.

Looks like the formatting could be a problem


I just had a quick look at your import xml file and noticed that you read the CSV directly and created the corporate units in the same import step.

I usually do a staging step first, just transferring the data from the CSV to the database. Then do a second import step consuming the data from the staging table for the actual element creation/update.

Do you use a physical table to store the CSV data to check how it was imported?

Best regards,



No, we never used the staging step, we directly import the data from csv to database, which always worked.

In fact, we tested the same on our dev environment, which is successfully creating the structure as expected - but here on dev environment - we never faced delimiter issue, so we are not using any schema.ini file.

However, we are facing delimiter issue on production - so we using schema.ini file and then ran the same steps to import the same csv, but instead of creating structure, these records are created as separate records,

So isn't it looks like an issue when we use schema.ini file ? having multiple separators ... one from schema.ini and another "/" from BAS for corp units?

@LorenDon - Yes, this does seem to be some type of parsing issue with the CSV, I was able to replicate the issue in my 2019 R2 environment.  It created 3 separate corporate units, all at the same level.

I then opened up your CSV with Excel and saved it as an Excel spreadsheet.  Reading the data as Excel, the imported results were as expected, where the business units were created as a tree structure.

Would it be possible for format your data as Excel instead of CSV?


yes, the excel format is working fine.

Also, with out any changes made, today we are able to create corp structure properly with out any issues. Not sure what is the reason, but issue is solved. Many Thanks.

I have a question on how to use Find/Replace option in BAS... I shall post as a separate topic