TeriStevenson
Frequent contributor

Bypass Flexera gateway

Jump to solution

We are upgrading FNMS to the latest version and we currently have the gateway installed on our old version.  We only use FNMS and App Portal so we don't need to use the gateway.  I read an old solution by Charles previously on a sql update that needs to be run on App Portal if you no longer want to use the gateway but I am unable to find it.

I'm hoping someone has that old post for the solution.

0 Kudos
1 Solution

Accepted Solutions
CharlesW
Flexera
Flexera

Re: Bypass Flexera gateway

Jump to solution

First, go to settings->Flexera Integration, and remove the value that you have defined for "Flexera Service Gateway Server Name".. Save your settings.. Next, run the following query against the App Broker DB:

update dbo.WD_AppSettings 
set Value = ‘True’ 
where KeyName = ‘ShowFSGEndPoints’ 

After updating the DB, perform an iisreset.. Once you have done this, you should see some new settings exposed at the bottom of the settings->Flexera Integration page, which will allow you to define a static value for the path to the FNMS compliance API..  The URL you use will be similar to the following:

http://<FNMSServerName>/ManageSoftServices/ComplianceAPIService/ComplianceAPIService.asmx

The following screen capture shows this setting highlighted.

fnmsURL.png

View solution in original post

3 Replies
CharlesW
Flexera
Flexera

Re: Bypass Flexera gateway

Jump to solution

First, go to settings->Flexera Integration, and remove the value that you have defined for "Flexera Service Gateway Server Name".. Save your settings.. Next, run the following query against the App Broker DB:

update dbo.WD_AppSettings 
set Value = ‘True’ 
where KeyName = ‘ShowFSGEndPoints’ 

After updating the DB, perform an iisreset.. Once you have done this, you should see some new settings exposed at the bottom of the settings->Flexera Integration page, which will allow you to define a static value for the path to the FNMS compliance API..  The URL you use will be similar to the following:

http://<FNMSServerName>/ManageSoftServices/ComplianceAPIService/ComplianceAPIService.asmx

The following screen capture shows this setting highlighted.

fnmsURL.png

View solution in original post

jdempsey
Moderator Moderator
Moderator

Re: Bypass Flexera gateway

Jump to solution

Charlie and I don't normally disagree, but as I think I replied in the previous thread, I don't recommend doing this except as a last resort.  Flexera products were built to work with the gateway for a reason, which includes potential product changes in the future.  If you bypass the gateway, some future product change could cause your use cases to stop working (probably low chance, but why risk it?).  The gateway is a very lightweight service that can run directly on your App Broker server (or anywhere else, for that matter).  If any of your products are having issues talking to the gateway, that probably signifies a deeper issue that should be addressed at the root cause, rather than ignoring it and bypassing the gateway.  The most common issues I find related to the gateway not working are either that it's installed on a remote server with a firewall in the way (either network or personal), or there is a missing configuration related to TLS settings.  Either way, these are relatively easy to fix, so there really isn't a need to bypass the gateway to resolve them.

Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".
CharlesW
Flexera
Flexera

Re: Bypass Flexera gateway

Jump to solution

No comment 😀

0 Kudos