Showing results for 
Show  only  | Search instead for 
Did you mean: 

Repackaging Adobe Acrobat Writer 5.0.5

Hi All,

I have repackaged Adobe Acrobat Writer 5.0.5 with Admin Studio in Windows Installer format (.msi). When I install my package interactively, everything installs and functions properly. However when I publish my package through the Active Directory and install through the Add/Remove Program, the PDF Port does not get created.

Both installation methods were tested with local admin and users with admin privileges and also elevated privileges on AD. All tests are based on Windows XP and similar tests were performed on Windows 2000 with the same results.

I also compared the registry keys for the PDF port on both instance of installation and they were similar. Creating the port manually was also unsuccessful. Any help or suggestions would be much appreciated. Thanks in advance.
(33) Replies
By Level 11 Flexeran
Level 11 Flexeran
I've replackaged this product too and the device wont show up until a reboot has been made. I just got out of studio class and the instructor gave alot of warning to repackaging this product or any product that adds a device because it checks current hardware drivers on the machine. I'm not saying that it cant be done, just be careful and i hope most of your machines are similar.
You are correct that the printer does not show until after reboot. I did consider that hardware devices may be a factor, however, my tests were also performed on the machine I repackaged Acrobat Writer on. Regardless, the package functions well when installed interactively.It is only unsuccessful when published through the Active Directory.
I've have tried a couple of different ways to install this product after a successful capture and nothing seems to work when it comes to installing the print drivers for the file conversion. There was a post on these boards with a reg file that shows the changes that need to be added to the build (*.ism) file and this was also unsuccessful. In your post you said that when the software was installed interactively it installed fine. What do you mean by interactively?

Thanks in advance.
What I meant by interactive was to install the application by double clicking on the msi file.

Here are the steps I took to repackage Adobe Acrobat Writer 5.0.5.

1. Run initial scan with Multiple Steps
2. Run Setup
3. launch application
4. Run scan to complete capture
5. insert reboot in installexecutesequence
6. install package by running the msi file, ensure it installs to the allusers profile. Use the local administrator account.
7. pdf port should install after reboot

all repackaging should be performed on a "clean" workstation, OS +SP only.

let me know if there are any other questions. If there are questions concerning the deployment of the msi package, please send me an email.

Nicholas Ong
In your step 5 you show

5. insert reboot in installexecutesequence

I've tried reboot and it doesn't like, tried ForceReboot = F {sequence} 3151 and I get the error

"ForceReboot action in InstallExecuteSequence table in wrong place. Current: PostExecution, Correct: Execution"

I am not sure where I made the mistake.

By the way thanks for your assistantce on this. I am still new to all this.
No problem at all! 🙂

In your InstallExecuteSequence table, under sequence 502 you should see a ScheduleReboot action with a condition of ISSCHEDULEREBOOT.

Changing this condition to Not Installed will ensure that the reboot prompts only after the initial installation. Leaving it blank will prompt for a reboot after install and also removal.

Did you have any luck with the pdf port?
I was succesful with getting the machine to restart and then after logging back into the system it completed the install but it is still missing the pdf distiller printer and the PDF writer. hmmmm I really don't think Adobe likes to play well with others ya know.
Sounds like you are seeing the self healing after reboot. Check your application log in event viewer to see what was deleted after reboot. You may want to remove that component from your package.

As for the printers not showing up, I'm totally surprised. You should at the very least see the PDF Writer printer icon. The exclusion list might be preventing a proper capture. Give it another shot without the exclusion list.
I am attempting to recapture with a limited exclusion list and see if that works. I will post shortly with the results. :o)
All is well. What I found was mostly at fault was our exclusion list that we are using. I will have to get with my bosses that created the exclusion list that we are using in order to adjust what we are excluding. Thanks for all your help with this. :o)
This post and the PDF Port post reflect the problems I'm having with repackaging Adobe Acrobat 5.0.5.

I also don't see the printer until after a reboot, and when I DO see it, it is offline, and with no port value, even though there are SIX references to that port value in the registry!

I have tried to follow everything suggested in the various postings, but no luck.

Two questions:

2. How do you make sure that it is an "AllUser" install?
1. In the InstallExecuteSequence table, for the action ScheduleReboot, change the condition to Not Installed. You can also leave it blank.

2. The alluser means that the package will be installed into the AllUsers Profile. It is the same result as when you run the msi interactively (doubleclick) using an account with administrative privilege.

It sounds like you are extremely close to getting a complete package so don't give up just yet. Try searching through the registry from the original install and look for the word port. Export those registry keys and import them into your package. If it still doesn't work send me an email and I'll send you my registry file.
Nicholas -- I did as you said, and found 658 lines in the registry for the distiller printer. Extracted them, imported them to the package in Developer, rebuilt, validated, and distributed to a clean XP machine. Installed via double-click to the MSI. 😞 Still the same -- After reboot (now semi-automatic -- thank you, thank you!) the distiller printer is there -- still offline, still with no port address (c:\Documents and Settings\All Users\Desktop\*.pdf).


When you did the initial capture check your exclusion list for anything envolving hardware. I found that we were excluding much from these entries and when I removed them and recaptured it did pick up the differences. It still did require the reboot but it did setup the printers and the ports.
Can you quote the keys needed? I've spent quite a bit of time trying to find exclusions which would make a difference, and can't.

In our *.ini file that is used for the exclusion list I have two listings that I had to remove. I have listed the two below.

Scott -- Dug through the default.ini in the repackager. Found the first one and removed it. Could not find the second. Reran everything. Still installed the same way. Distiller Printer is there, offline, and NO port.

Scott -- Found the other one in defaultoss.ini. Am ready to try it. I'll let you know. (Didn't realize I had to look in TWO ini files).

During your repackaging, did you reboot before performing the end capture?

Do a search through direct editor for the computername where you had performed the capture and also for "alluserprofile", it should be C:\Documents and Settings\All Users.
When doing the initial capture (native install) I did not have to reboot the system. However, after creating the msi I had to force a reboot in order for the printers and ports to work.