sreeramyenuga
Level 6

issue with FNMS installing in Azure cloud with local sql server

Hi,

we are building a FNMS setup in Azure with local SQL DB installed on azure, The SQL Database installed locally on Azure VM having a copy of existing database from our on-prime setup. while  installing the config running script getting below error.

Executing step Deploy adoption and upgrade packages.
FlexNet Manager Suite installed at ':\Program Files (x86)\Flexera Software\FlexNet Manager Platform\'
FlexNet Manager Suite package repository detected at ':\ProgramData\Flexera Software\Warehouse\Repository'
Checking to see if there is a pending deployment...
No pending deployments found. Creating lock file at :\ProgramData\Flexera Software\Warehouse\Staging\LockFile.
Receiving adoption packages...
Receiving upgrade packages...
Preparing beacon self upgrade package...
Packing all packages...


FlexNet Manager Platform Console Distributor
Version 13.2 (8.1104) for Windows x86
Copyright 2019 Flexera Software LLC

nddistrib failed with exit code: -1073741819
At C:\Temp\2019R1\Support\DeployPackages.ps1:139 char:3
+ throw "nddistrib failed with exit code: $($process.ExitCode)" ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OperationStopped: (nddistrib faile...de: -1073741819:String) [], RuntimeException
+ FullyQualifiedErrorId : nddistrib failed with exit code: -1073741819

Thanks,

sreerama yenuga

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

6 Replies
sreeramyenuga
Level 6

Please any help on this any inputs @ChrisG , @mfranz , @kclausen 

Thanks,

Sreerama Yenuga

0 Kudos

Hi,

have you checked what "DeployPackages.ps1" line 139 char 3 says/does?

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos

Dear @mfranz ,

throw "nddistrib failed with exit code: $($process.ExitCode)";

This is what i seen in the code line 139.

Thanks,

SREERAMA.YENUGA

0 Kudos

Ok, from there you should be able to backtrack why this was thrown. Please look at the lines above, the script must have been trying something that actually failed.

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos

Dear @mfranz ,

in the below snippet the highlighted code marked as bold and underlined is throwing error.

#########################################
# Pack and send packages to ManageSoftDL
Write-Host "Packing all packages..."

$nddistrbExe = "`"$InstallDir\Distributor\nddistrb.exe`""
$arguments = "-c Distribute -t Package -o DontDistribute=TRUE -o DoDependencies=TRUE -o ForcePack=TRUE"

ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Adoption/$ComplianceVersion/Rev1.0/Managed Device Adoption/Managed Device Adoption`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Upgrade for managed devices/Upgrade for managed devices`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Upgrade for ManageSoft for AIX Managed Devices/Upgrade for ManageSoft for AIX Managed Devices`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Upgrade for ManageSoft for HP-UX Managed Devices/Upgrade for ManageSoft for HP-UX Managed Devices`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Upgrade for ManageSoft for Linux (i386) Managed Devices/Upgrade for ManageSoft for Linux (i386) Managed Devices`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Upgrade for ManageSoft for Linux (x86_64) Managed Devices/Upgrade for ManageSoft for Linux (x86_64) Managed Devices`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Upgrade for ManageSoft for Mac OS X Managed Devices/Upgrade for ManageSoft for Mac OS X Managed Devices`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Upgrade for ManageSoft for Solaris (sparc) Managed Devices/Upgrade for ManageSoft for Solaris (sparc) Managed Devices`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Upgrade for ManageSoft for Solaris (x86) Managed Devices/Upgrade for ManageSoft for Solaris (x86) Managed Devices`""
ExecNddistrb $nddistrbExe "$arguments -i `"Package/Flexera/Upgrade/$ComplianceVersion/Rev1.0/Flexera Inventory Beacon Upgrade/Flexera Inventory Beacon Upgrade`""
#################################################

0 Kudos

Doing an Internet search for the error code "-1073741819" suggests that this may be related to some sort of access rights problem.

Are you running the Config.ps1 script from a PowerShell console that has been opened with full local administrator rights?

As a diagnostic step, you could try running the following command in a PowerShell window to see whether it gives any further output that may help to identify what is going on:

& "C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\Distributor\nddistrb.exe" -c Distribute -t Package -o DontDistribute=TRUE -o DoDependencies=TRUE -o ForcePack=TRUE -i "Package/Flexera/Adoption/13.2.0/Rev1.0/Managed Device Adoption/Managed Device Adoption"

 

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)