Smitty987
Level 6

FlexNet 2020 R1 - agent auto upgrade

Hi,

Has anyone managed to run the auto agent upgrade without any issues?

I've got it running and having various problems with the upgrade either not running or failing and removing the installed agent.

I've got a large proportion of the estate upgraded but the ones with errors are making it hard work.

Any input gratefully received

Thanks

Labels (1)
0 Kudos
4 Replies
mag00_75
Level 7

Hi

Not the answer to your question, but maybe give some ideas

I dont think the 2021 R1 is out yet, which version are you using? 16.0.1/2020R2

I have successfully run some auto upgrades on windows to 2020R2, but on The linux testserver it didnt work and I’m waiting to get the ligs from the server

Historically I had some issue that the beacons didnt replicate the installation packages, think it was 2019R1 or R2.

I have also read that in the version history for the cloud agents, it was mentioned a bug fix for that auto upgrade deleted hklm tree for flexera/managesoft

Thanks - obvs a typo - we are using 2020 R1 on premise. Had quite a lot of success with all OS but some still causing issues.
0 Kudos
ChrisG
Community Manager Community Manager
Community Manager

(Mod: I've updated the version "2021" to "2020" in the subject of the initial post on this thread.)

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos
joshua_neadow
Level 4

we are experiencing a similar issue.  it looks as though that the Device is getting the upgrade package from the beacon.  Once it tries to upgrade, all of the executables disappear and the agent no longer checks in.

0 Kudos