Some users may experience issues accessing the case portal. For more information, please click here.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Azure connector for china tenants not working


i was testing to use Azure connector to gather China vm  information.

while testing connection on the (2019 R1) beacon i am getting an error "AADSTS90002 Tenant not found. This may happen if there are no active subscription for the tenant."

However i could login to the tenant ID using the same SPN via power shell and see the VM objects inside its subscription.

Can some help understand why this error occurs while connecting via the FNMS beacon   

Note : The same beacon is configured with a different Global tenant and it works properly. 

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

2 Replies


I know that you're working with support that has suggested a workaround. Please inform the community with your findings when you've got the workaround implemented.


0 Kudos

Hi @JohnSorensenDK ,

you can use the below mentioned workaround to connect with secure Azure environment like China, US secure and Germany.

on the FNMS application server

  • Access the following path "\ProgramData\Flexera Software\Compliance\ImportProcedures\CustomInventory\Reader\"
  • create a copy of "Microsoft Azure" folder and rename it to the secure environment name i.e.  "Microsoft Azure - China only"
  • access the Microsoft Azure - China only folder and edit the logic.ps1 file with any text editor
  • wherever the "Connect-AzureRmAccount" is mentioned in the logic.ps1 file append the following environment switch command without quotes "-Environment AzureChinaCloud" at the end of the command and save the file. 
    • you can get other secure environment switch from Microsoft Azure sites.

On the FNMS Beacon 

  • update the beacon policy to make sure the changes made is reflecting.
  • create new power-shell connection under inventory systems on the beacon application. 
    • under "source type" drop-down  you should see the  "Microsoft Azure - China only" option, use this option to connect China environment.

Thanks @jevans and team for providing this workaround.