dbeckner
Consultant

ESDService not retrying collection inserts after error

Jump to solution

I've noticed twice now that when the ESD Service encounters an error when attempting a collection insert it does not attempt another one until the ESD Service is restarted. Is this by design?

App Portal v2018 R1

0 Kudos
1 Solution

Accepted Solutions
dbeckner
Consultant

Re: ESDService not retrying collection inserts after error

Jump to solution

For those that may run into this issue -- the issue was actually caused by removing the email from site alerts in the admin panel. This was causing the ESD service to stop. The information for that ESD service stoppage is referenced and resolved in this KB article.

 

https://community.flexera.com/t5/App-Broker-Knowledge-Base/ESD-Service-Stops-Unexpectedly/ta-p/16364...

View solution in original post

3 Replies
CharlesW
Flexera
Flexera

Re: ESDService not retrying collection inserts after error

Jump to solution

If App Portal fails to insert a device, it should set the InsertDate in the WD_PackageRequests table to the current time, plus 1 hour.. It will continue this process indefinitely until the insert is successful.  Even if you were to restart the service, I'd not expect that the insert would take place until the 1 hour has elapsed.. Is the service stopping? Are there a large number of failures occurring at the same time? I'd start by looking at collectionInsert_<server>.log.. If you see an insert count in excess of 100, then you may be running into a scenario where the collection insert is blocking due to a large number of failures. I do seem to remember an issue in older versions where multiple inserts might be running at the same time due to this backlog.. Let me know if you are seeing a large number of failures in the above mentioned log file.. There are a couple of things we can do.. The best being cleaning up the failures..

0 Kudos
dbeckner
Consultant

Re: ESDService not retrying collection inserts after error

Jump to solution

@CharlesW The error wasnt a failed insert. The error was "Dataset returned from <SCCM Server> was invalid....Server was unable to process request. Object not set to an instance of an object..." -- This error occurred on 2/19 at 6pm and no collection inserts were attempted until this morning when i restarted the service. All orders until the restart had a pending status without any machine policy messages.

0 Kudos
dbeckner
Consultant

Re: ESDService not retrying collection inserts after error

Jump to solution

For those that may run into this issue -- the issue was actually caused by removing the email from site alerts in the admin panel. This was causing the ESD service to stop. The information for that ESD service stoppage is referenced and resolved in this KB article.

 

https://community.flexera.com/t5/App-Broker-Knowledge-Base/ESD-Service-Stops-Unexpectedly/ta-p/16364...

View solution in original post