dbeckner
Consultant

vCenter API version 6.0

Does FlexNet Manager support the inventory collection from vCenter version 6.0.0 and API version 6.0?

I am troubleshooting failed inventory from a vcenter using the same credentials used successfully on 3 other vCenters. The log is reporting --

<Message>Failed to login to web service https://<X.X.X.X>/sdk<Message>
<Message> SOAP fault: Cannot complete login due to an incorrect user name or password.<Message>

The same service account is being used for this server as all the others that are successful.


One thing I am noticing is that the API Version is 6.0 while the other successful vCenters are 6.5 and 6.7.

 

TIA.

0 Kudos
3 Replies
ChrisG
Community Manager Community Manager
Community Manager

I think it is unlikely this issue is specifically related to the version. Current versions of FlexNet Manager Suite support VMware vSphere/vCenter/ESXi versions 5.0–6.7 u3b and 7.

See Compatibility with Other Products for current compatibility details.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
kclausen
Flexera
Flexera

Yes, I agree with Chris.  I would take your error message at face value that your vCenter 6.0 SDK is not accepting the logon credentials on the Beacon.  If you launch a browser, go to the URL of the SDK (https://<X.X.X.X>/sdk) and put in the credentials, do they work?

0 Kudos
jasonlu
Intrepid explorer

I agree that proving the credential work is a first step.

This may not be your case, but if CyberArk password store is configured on your beacon, there is a known issue whereby some passwords with special characters cannot be passed correctly from the CyberArk safe to the beacon, and then you end up with a bad credentials error.

With that customer we ended up having to change the service account passwords so something much simpler.

j