Showing results for 
Show  only  | Search instead for 
Did you mean: 

Zero footprint Inventory not uploading through HTTPS

Good day

We have configured zero footprint inventory on FNMS but receiving the below error:

[9/29/2020 4:37:35 PM (N, 0)] {2656} Error 0x800B0109: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.
[9/29/2020 4:37:35 PM (N, 0)] {2656} Error 0xE050044D: Failed to create remote directory /ManageSoftRL
[9/29/2020 4:37:35 PM (N, 0)] {2656} Error 0xE0690099: Specified remote directory is invalid, or could not be created

HTTPS is in use.




(6) Replies

@iammanzi - For Zero footprint inventory, HTTPS communication is not supported for Linux/UNIX.  This is documented in the Gathering FlexNet Inventory Guide.  Go to the following link and scroll down to the Communication Protocols and Ports section.

Tip: HTTPS is not supported for UNIX-like platforms in the Zero-footprint case.


Hi @kclausen - Apologies, i forgot to mention this is happening on Windows.


You may want to raise a support case on this to get assistance troubleshooting your issue.

Please update this community thread afterwards with the resolution of your issue if you think other forum members could benefit from it.



It look like a certificate issue error, can you check if your root CA is trusted by the machine?

Or can you disable the certificate check when you upload your inventory, I know that this is security issue and is not recommended, but for testing reason, you can try it.


based on the recommendation (for testing only) of @adrian_ritz1 , here are the necessary commands.

ndtrack.exe -t machine -o Upload=True -o UploadLocation=https://server/ManageSoftRL -o CheckServerCertificate="False" -o CheckCertificateRevocation="False"


Please also check that the complete certificate chain of the beacon server can be resolved by the agent and/or that the certificates are available in the store.



@JohnSorensenDK , @dennis_reinhardt , @adrian_ritz1 , @kclausen 

Thanks for the advice. The issue after alot of back and forth with Security was the certificate itself. By issuing the correct cert the issue is resolved.