Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to Load AWS Tools for Windows PowerShell

By Level 10 Champion
Level 10 Champion

We are attempting make this connection with AWS EC2. We have setup all the pre-requisites in AWS and on the beacon including installing the AWS Tools PowerShell modules. Running "Get-AWSPowerShellVersion" returns the correct version of the module; however, when configuring the connection in the beacon or running an import the connection fails because the beacon cannot load the AWS Tools module. Diving into the Reader file in the adapter I noticed that the path where the adapter looks for the module is  "C:\Program Files (x86)\AWS Tools\PowerShell\" which can be found in the function InitializeAWSHelper. I do not see the requirement to install the AWS Tools module into this directory in the documentation. Manually dropping the module files to this directory also fails. Am I missing a step and has anyone else run into this?



(1) Reply
By Level 3 Flexeran
Level 3 Flexeran

The adapter doesn't require the module to be in this specific path in order to work, it should look in this path in addition to all the other paths defined in the PSModulePath environment variable. Where did the module get installed when you ran the Install-Module command? You can run '$env:PSModulePath' in PowerShell to get the list of module paths and it should be in one of these.

I just read that in PowerShellGet version 2.0.0 and higher the default option for the -Scope parameter was changed from AllUsers to CurrentUser. If you find the AWS tools in your user's module path, then it probably won't be available to the beacon which runs as the SYSTEM account by default. Try uninstalling the module and re-installing it with '-Scope AllUsers'.

The online help takes you to the legacy bundle aws tools which includes all cmdlets. Make sure it's this one you have installed and not the modular version which I think you'll get to through google. We haven't documented which individual modules are required yet but if you did want to try that it should just be: