spencer_clark
Occasional contributor

Import failed. Error: UseForMatching, must be set for the following objects: [Asset].

Jump to solution

We have a custom Biz Adapter for Service Now in Production.  I was asked to make another one in our dev (points to UAT FNMS Cloud) for trying some new options.

Getting an error I've never seen before when executed:

 

Import failed. Error: The required property attribute, UseForMatching, must be set for the following objects: [Asset].

I cannot find a "UseForMatching" option anywhere on the adapter.  Does anybody know what's going on?

 

Thanks!

1 Solution

To expand on what @dennis_reinhardt mentioned here is a screenshot showing where it can be set in the Business Adapter Studio. It can also been set in the adapter XML file as an attribute of the property as in the second image which is from the documentation.

- Bill

View solution in original post

4 Replies
dennis_reinhardt
Frequent contributor

Hi,

this function/feature was added in the June 2020 cloud release (https://docs.flexera.com/fnms/EN/features/index.html#FeatureList/2020R1/RN-chg-UseForMatchingReq.htm...

Check page 209 in the BAS manual so get detailed information about the "UsedForMatching" Checkbox (https://docs.flexera.com/fnms/EN/WebHelp/PDF%20Documents/Cloud/UsingFlexNetBusinessAdapters.pdf)

You've to define one or more values to identifiy the object in the database to update object data.

 

Best, Dennis

To expand on what @dennis_reinhardt mentioned here is a screenshot showing where it can be set in the Business Adapter Studio. It can also been set in the adapter XML file as an attribute of the property as in the second image which is from the documentation.

- Bill

View solution in original post

spencer_clark
Occasional contributor
This was helpful!! Thank you!!
0 Kudos
Thank you - sorry for the late reply but this worked!!
0 Kudos