msutharh
Intrepid explorer

Download failure: Error 0xE0500013: Timeout on connection

We have FNMS 2019 R2 on-premises.

Recently we observe that many machines are not able to download policy files. We have uninstall FNMS agent in one machine then delete managesoft folder and install agent again but while downloading machine policy file it gives error.

Download failure: Error 0xE0500013: Timeout on connection

When copy Download URL from installation log file and paste it in browser then browser does not show any result also file is not downloaded and it is showing waiting.

0 Kudos
6 Replies
jjensen
Flexera Alumni

Hello @msutharh,

From the agent device, what is the result of navigating to <BeaconURL>/ManageSoftDL/test in a browser?

The error suggests a connectivity issue between agent and beacon. Can you telnet over port 80/443 from agent -> beacon?

Do other agents seem to be reporting in to this beacon OK?

HTH,

Joseph

If my response answered your question satisfactorily, please click "ACCEPT AS SOLUTION" to heighten visibility for future customers!
msutharh
Intrepid explorer

Beacon URL is accessible from client machine.

I am able to telnet on port 80 and 443 both. Yes, other agents reporting is ok.

0 Kudos
batfred
Flexera beginner

We have FlexNet Manager Suite 2020 R2 agent 15 and facing the same problem on many machines. Some machines could connect and some not.

Even worse, some could connect and now running into the same downlad failure on windows - all are 2012 R2 machines.

We can connect without problems by browser and download the files.

But running the mgspolicy - Machine gives the time out error.

Do you have any idea what happened or what we can do to solve this mystery?

0 Kudos
ChrisG
Community Manager Community Manager
Community Manager

@batfred - your browser being able to connect to a URL that FlexNet inventory agent processes are failing to connect to could be a symptom that access to the URL is going through a web proxy that the browser is configured to use but the agent is not configured to use.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

Hello,

I usually test the connection with powershell: 

test-netconnection -port 443 -computername <host name of the beacon>

I found this commend very useful because some time I found that the ping is working from server to beacon but the port is closed, other times is the ping disabled but the port is open.

 

Thanks for your hints.

I've disabled the SSL settings of IIS from accept to ignore - seems to work for some systems. 

To execute the mgspolicy  on all affected machines will take some time. I will then check the rest with your suggestions.

 

 

 

0 Kudos