junaid_vengadan
Intrepid explorer

Cognos URL is pointing to SAML after enabling the SSO at FNMS side only

hi,

I have enabled Single Sign On (ADFS) with FNMS for user authentication .

Now, when i open  the cognos (from my analytics link at FNMS Reports) , the cognos url is redirected to SAML Link 

https://COGNOSURL.com/ibmcognos/sso/Login/Login?ReturnUrl=%2Fibmcognos%2Fbi%2F&FnmsAuthType=Saml

 

Note that i have not enabled the SSO at cognos side at all.

 

When i change web.conf at fnms back to windows authentication and it seems working fine (means the congos url is coming as expected https://COGNOSURL.com/ibmcognos )

Regards,

Junaid Vengadan

0 Kudos
4 Replies
JohnSorensenDK
Moderator Moderator
Moderator

@junaid_vengadan 

There are specific steps related to Analytics (Cognos) outlined in Configuring FlexNet Manager Suite as a SAML Service Provider that need to be followed. Did you follow these steps?

Thanks,

@JohnSorensenDK 

 

Yes i was following the same documentation, infact the SSO is working fine for FNMS authentication but causing the above mentioned challenge when accessing Cognos

0 Kudos
JohnSorensenDK
Moderator Moderator
Moderator

@junaid_vengadan 

I can see that you've got a support case opened already on this issue, so I'm sure you'll get assistance troubleshooting.

Please share its resolution with the community if you think other members would benefit from it.

Thanks,

Hi @JohnSorensenDK 

we couldn't find the reason why the cognos URL was redirecting to SAML or ADFS SSO.

 

As it was taking time to troubleshoot  and the URL is already pointing to SSO, we enabled the SSO for cognos as well 😉

once we enabled SSO for Cognos , the URL still directed to https://COGNOSURL.com/ibmcognos/sso/Login/Login?ReturnUrl=%2Fibmcognos%2Fbi%2F&FnmsAuthType=Saml ( but this this time it received the SAML and further redirect to cognos page )

My personal suggestion is , use SAML authentication is cognos as well if we use SAML in FNMS.

 

Regards,

Junaid Vengadan

0 Kudos