cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

SCCM App Dependencies

I'm trying to create an AppPortal catalog entry for a SCCM Application that has a dependency.  The primary (dependent) application.. A license registration script and the dependency is the client install (which is installed if it currently does not exist)

From my initial testing, the dependency installs fine, but the dependent application (license registration script, in my case) does not run

When executed from within SCCM App Catalog, both apps install perfectly fine.

 

Using AppPortal 2019R1

0 Kudos
1 Reply
Moderator Moderator
Moderator

Re: SCCM App Dependencies

I'm not sure I can explain what might be happening in this situation (I would expect it to work).  Have you looked at the deployment settings for the deployment created by App Portal and compared it to the deployment settings for the deployment that was manually created in SCCM (i.e. the one that works)?  Have you looked at the SCCM client logs or server messages to see if the client is properly evaluating the dependency condition?

If you can't figure it out, you might try one of the following possible alternatives:

  1. Have your catalog item install the dependency (client application), then have the license registration script attached as a Command Script action to the On Success Install event for that catalog item.
  2. Use a non-OSD task sequence to install the client application and then run the license registration script.
  3. Re-package the client application to include the license registration script as an MSI custom action.

 

Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".
0 Kudos