Showing results for 
Show  only  | Search instead for 
Did you mean: 

SQL Conflict Database Upgrade

When I try to upgrade the conflict database with AdminStudio 5.01 I get the following error:

"AdminStudio Application Catalog upgrade failed."

Can Anyone help?

(7) Replies
By Level 11 Flexeran
Level 11 Flexeran
The upgrade process runs a SQL Script. Looks like because of the date format issue (the script has some dates in mm/dd/yyyy format) the upgrde is failing.

Please try the following:

a.) Make a backup copy of the file AMS_Data.SQL present under Program Files\InstallShield\AdminStudio\5.0\Support. Unzip the attached file and replace AMS_Data.SQL with the attached SQL Script file. Run the upgrade if it still fails, please try the next step.

b.) Start Regedit, and browse to HKEY_LOCAL_MACHINE\SOFTWARE\InstallShield\AdminStudio

Create a new string value key named DebugLogLevel and set its value as 3. Run the upgrade again, and it would generate a detailed log file. If the upgrade was started using main AdminStudio IDE then the log would be in AdminStudio.log, else if the upgrade was started from ConflictSolver, then the log text would be in ISCMIDE.log.

Please email me this log file at

Darshan Singh
PS: Once everything works fine, remember to remove the DebugLogLevel key.
Thank you for the quick advice.

The new AMS_Data.SQL works correct and the ConflictSolver database was succesfully upgraded.

Greetings from Germany...
By Level 11 Flexeran
Level 11 Flexeran
I seem to have a similar problem, have tried to upgrade or to create new application catalog, nothing seems to work, get “This is not a valid Workflow/conflictSolver Database”.

Also tried the new script you provided, but it doesn’t seem to work.

I admit though that I don’t know the first thing about SQL 🙂

Question: the AMS scripts are they only for Enterprise server ? I run professional edition and I was thinking that AMS= Application Management System and that this wasn’t included in professional edition.

Attach a log from my last attempt.
By Level 11 Flexeran
Level 11 Flexeran
Which version of SQL Server/MSDE you are connecting to??

If you have SQL Server client tools installed, you can start Query Analyzer (ISQLW.exe) and type


to find out the version information.

From the log, it looks like, the datatype SYSNAME is not being recognized.

New database creation in AdminStudio 5.01 (SP1) always runs AMS scripts as well, irrespective of if AMS is installed or not, or if it is Enterprise or Professional release.

Please email me the version information at

Try the following:

a.) Start Queary analyzer (ISQLW.exe).
b.) Create new database using following command:


-- make this the current database

USE AdminStudioDB

***IMPORTANT: Before running the following scripts, search for SYSNAME and replace it with varchar(128).***

Now, open AS_System_Schema.sql from the support folder and run it in this database (to run the script in Query analyzer, open the file [Ctrl+Shift+P] and then click on green arrow or press Ctrl+E or press F5).

Next, open AMS_System_Schema.sql from the support folder and run it in the same database.

Finally, Open AMS_Data.SQL (use the attached SQL File).

Now, start ConflictSolver and connect to this database (AdminStudioDB)
By Level 11 Flexeran
Level 11 Flexeran
Make sure you select the newly created database while running the script (you can select the newly created database from the database list combo box in Query Analyzer, or press Ctrl+U and select this newly created database [AdminStudioDB] from the list), and then run the scripts in this database.
By Level 11 Flexeran
Level 11 Flexeran
after the modifications i still cannot create a database.
Have included my latest log.
By Level 11 Flexeran
Level 11 Flexeran
I think the script is failing because it assumes "case insensitive" SQL Server. However, looks like you have SQL Server with case-sensitive sort order.

In SQL Query Analyzer (ISQLW.exe) you can run following T-SQL to check the sort order:

EXEC sp_helpsort

There are only four lines in the script which are causing the problem, these four lines are (I have updated and changed PKGROWID_ to PkgRowID_):

SELECT * FROM [cstblConflictResultsDestPkgs] WHERE [PkgRowID_] = @PkgRowID
SELECT * FROM [cstblConflictConfiguration] WHERE [PkgRowID_] = @PkgRowID
SELECT * FROM [cstblConflictPackages] WHERE [PkgRowID_] = @PkgRowID
SELECT * FROM [cstblConflictResults] WHERE [PkgRowID_] = @PkgRowID
SELECT * FROM [cstblConflictTransformList] WHERE [PkgRowID_] = @PkgRowID

This change should fix it.

I have included an updated script with this post, please replace this file in your support forlder and then create new database using AdminStudio IDE.