Showing results for 
Show  only  | Search instead for 
Did you mean: 

Repackager - Only getting initial snapshot

I have been using repackager for years with no issues but recently I tried to run the Multiple Steps snapshot but it only takes the initial system status and not any changes.

Admin studio is installed on my host PC and I run repackager on a VM remotely. I can analyze the initial system status, perform any installations and config but when I run repackager again it doesn't perform the analysis for the changes. it just wants to do the initial snapshot again.

Nothing has really changed on the Host PC or VM, last time I had to use repackager was about a year ago and was working fine. Anyone has seen this issue before please?


(3) Replies

Ok I realised that Repack.exe is just crushing

Faulting application name: Repack.exe, version:, time stamp: 0x55b5a489

Faulting module name: ntdll.dll, version: 10.0.19041.1023, time stamp: 0xf739c3a5

Exception code: 0xc0000005

Fault offset: 0x0008745c

Faulting process ID: 0xbac

Faulting application start time: 0x01d76845aac5b2f0

Faulting application path: \\pc0039197\c$\Program Files (x86)\AdminStudio\2015\Repackager\Repack.exe

Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll

Report ID: a4d03901-ede6-40ba-9407-63ba0ecf93cd

Faulting package full name:

Hi Nutella,

Are you repackaging on a clean OS? Preferably one that is a snapshot of a clean machine and reverted each time for repackaging.  Does this error also happen for all packages or just the one?

What is the State value of this reg key set to?

"HKCU\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing"


Thank you.

Thanks for your reply

AdminStudio is installed on a win10 PC (20H2) and i'm running repackager remotely on a clean VM (tried both 1909 and 20H2). The packages don't matter, repack crashes on the initial system status (snapshot, multiple steps). I even created a new VM, same issue, installed standalone repack on both the VM and host and still crashes. 

The key below is set to, State 0x00023c00 (both host and VM)

I'm starting to think it might just be the version of AdminStudio, using 2015. It worked fine for all these years and I haven't had to use repack for about a year now. I think last time I used it the host pc was on 1803