Showing results for 
Show  only  | Search instead for 
Did you mean: 

Loadinjectiondriver failed. Error: 193 when repackaging

I've seen a few of these messages in the community but none of the resolutions are working for me. I am using AdminStudio 2023 Version 25 on Windows 10 22H2 (also my packaging machine). The first message is followed by the following:

InjectLibrary32 failed Error: 2

InjectLibrary64 failed Error: 2

UnInjectLibrary32 failed Error: 2

UnInjectLibrary64 failed Error: 2

I mapped a drive from the packaging machine to the AdminStudio server then ran the Repack.exe from there (using an elevated account), no good. Then I tried running the remote repackager on the packaging machine, no joy. Then I copied the Repack folder to my packaging machine and ran repack.exe, no joy. I ran the setup to install the remote repackager, it wanted to install Visual C++ 2015 Redist but a Visual C++ 2015-2022 Redist was installed, I removed those and let the setup install the Visual C ++ prereq. Still nada. Then I even tried running the repackager on the AdminStudio server and that didn't work. Everything was installed using my admin account.  I always end up using the Snapshot method but that grabs everything. 

Any thoughts?

Steve B

(4) Replies

Hi Steve,

Is the machine you're running repackager on a Clean OS? In other words a Clean VM with no applications installed? Just a plain OS from a Microsoft ISO, not a company ISO?

Hi and thanks for the quick reply!  It's a company image with all the bells and whistles. Due to our security policies, we are not able to create a clean packaging machine.  The Snapshot method works but we have to rely heavily on the exclusion list.  I am trying get the packaging machines on a lightly managed OU. There are some security applications that I cannot install, even with elevated permissions.  This is an issue that has plagued repacking machines for years. We just can't identify which software is causing this error. I agree that the best practice is a clean packaging machine but, unfortunately, that's not always possible. 

Hi Steve,
It's quite likely that one of the other applications is interfering with the repackaging. Can you at least disable all the security software for testing? There's not much we can do other than suggest trying on a clean VM.

There seemed to have been an issue with the Activation Code. Once I re-applied the activation code for AdminStudio. The Monitoring method on the Repackager worked. We also updated our standard image to windows 11. Antivirus and all.