Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problems building a repackage of exe to msi

I am trying to convert exe to msi. I am trying this using AdminStudio 8. I go through the Capture an Installation Using Repackaging Wizard and I've tried doing both the snapshot method and the Installation Monitoring method, those complete with no problems. I then try to build from the file created and I get an error about [] so I run the Scan the InstallShield Professional Setup for platform-dependent setup information and then run the build again and it no longer gives me the error about the [] but instead it gets to 'Loading registry entries' and does no more like it is froze. I let it sit at this for about 16 hours and it did not move so I'm confused to why it is having a problem loading the registry entries. I also tried the scan for setup intent too. Has anyone ever had this problem or know what I can try to fix it?
(1) Reply
I've seen some situations where this can take place when data of a certain type (i.e. files, registry, ini files) have more than 10000 entries.

If you are getting this extremely slow behavior with INI or Registry data, I would recommend checking the repackaged output to see if there's anything you can exclude. The more you're able to exclude, the quicker the build process will be.

For files (when it gets stuck at 'Creating Components for Files'), there's an easier workaround--simply move the repackager project files (*.irp, *.inc, *.nir, options.ini, etc.) to another folder and build just the *.ism project file. The trick with this workaround is to have the repackager not be able to reference the installation files, since it will try to populate the *.ism with data from these files, and this can be very slow.

Hope this helps.