Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issue creating Visio 2007 msi

Hello all,
I am new to using admin studio, so I have a question for some of the more experienced users.

I am making an MSI for Office Visio 2007. I am using the repackager tool and I have tried monitored installation and snapshot. The MSI creates successfully, and installs successfully, however.. when you go to launch the program, you get the error of "The operating system is not presently configured to run this application".

Many posts I have read on many forums suggest this is an issue with Microsoft office itself and to repair or reinstall. To test this theory, I have tried to run this self created visio MSI on 4 different machines (2 of them with no MS office suite installed). All machines have lead to the same error, which leads me to believe there may be an issue in the MSI creation process.

Like I said before.. I am VERY new to using Admin Studio, so if you have any helpfull tips, please keep it relatively simple 🙂

I am using Admin Studio 9.0 Enterprise, and the application is sitting on a MS server 2003 box.

Thanks again,
(1) Reply
Hi There,

Visio is already in MSI format, which means that to start with you'll want to just create a transform or otherwise manipulate the MSI it came with. I think that Microsoft generally supports silent deployment starting with the command:

setup.exe /admin

Some links that discuss this:

Office Customization Tool (OCT) overview

Deploying the 2007 Office system

Visio Professional 2007 12.x

As to the source of the error, I can't be entirely certain. But my educated guess has to do with how the office applications are written to run. Basically, Word.exe, Excel.exe, and I would assume Visio.exe each make Windows Installer API calls to see if the product is correctly installed, and that each keypath is present. Basically, if you rename word.exe to word1.exe it will kick off a repair.

Now, I've not seen the error message you're describing before but I would venture a guess that there's some other integrity checking that's not working quite right. The Office installs are very, very complex so it wouldn't surprise me if this was the case.

As an aside, I've generally seen that the Office applications will work Virtualized in an AppV package if you take the approach you're taking, and just build directly to AppV format, making sure to include the *.context.msi that Repackager builds.

Hope this helps!