Some users may experience issues accessing the case portal. For more information, please click here.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Installation Monitor option in Repackager does not work on Windows 7 64bit system

I am unable to use the Installation Monitoring option within Repackager (AdminStudio 11.5 SP1) on a Windows 7 64bit system. I have tried this in a Windows 7 vmware image as well a standalone system Here's what happens -

1. Launch Repack.exe from the Repackager folder on a Windows 7 64bit system. (Vmware or regular machine)
2. Choose Installation Monitoring option in the Repackaging Wizard.
3. Specify the installation you want to run( I tried an InstallScript MSI Based setup and a pure legacy install with the same result)
4. Repackager starts. It then launches the InstallMonitor64 utility, which errors out with "InjectLibrary32 Failed: Error 5"
5. Hit Ok and you will see another error - "InjectLibrary64 Failed: Error 5".
6. If you click Ok for both these errors, Repackager will continue on, but you won't get any output in the end as the InstallMonitor utility fails on Windows 7 64bit systems.

Note - I went behind the scenes and double clicked on ILaunch.exe, which is the InstallMonitor uitlity and I get the same error.

Has anyone been able to successfully repackage a setup on a Win 7 64bit system? I would think this would be a big issue if not. Not sure what's going on..Any help would be appreciated.
0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

1 Reply

I have absolutely been able to use Repackager with Installation Monitoring with AdminStudio 11.5 SP1 on 64-bit Windows 7 Enterprise.

I do remember seeing that error once quite a while ago (before AdminStudio 11.5 was released)...I think it was a permissions problem where I had to grant some permissions to the registry. Try using Microsoft Sysinternals "Process Monitor" to see if you're getting Access Denied errors from the registry or filesystem.

Also, reach out to Flexera Software support.
0 Kudos