Showing results for 
Show  only  | Search instead for 
Did you mean: 

SVM Patch Daemon as Local System?

I'm trying to run the SVM Patch Daemon so we can use Subscriptions for Automations. The service fails when run as Local system but, work fine when I run the service with an account.  I'm trying to avoid another Service Account and it seems to be supported running as Local System but, doesn't work. I worked with our Flexera Engineer but, we couldn't determine the issue.  We are using with SCCM but, integration is not turned on we are just publishing to WSUS.  Anyone running it as Local System and run into this issue? Not sure why it's making an API call to SCCM?

Exception during request /sccm/api/?action=patch_daemon&which=tasks&ui=svmpd&langroup=SCCM&ver= (retry in 533 ms): An error occurred while sending the request.

(I removed servername, token and GUID)



(3) Replies
By Level 2 Flexeran
Level 2 Flexeran

Hello Shawn,

The error relates to daemon not being able to connect to our server at SCCM directory. This is not your SCCM application.
This is related to a proxy. And it is not a standard practice to allow a Local System account through proxy.
Therefore, you require AD account which is allowed. This can be a service account or user's account.
Without a proxy, Local System account would be able to access the internet.

Alternatively, you can allow Local System account on this machine to access the internet via proxy, but again, it is not a standard practice. Hence, service account is recommended.


Hi Jerry,
One of the first issues we ran into was the proxy and we resolved this with a proxy exception and then were able to connect and get a token. So in the case you describe is the SCCM Directory on a different server /URL than what we requested and exception for?
It is enough to enable access to Product URLs as listed here: