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Symptoms:

.gz file upload is failing for Beacon-generated compressed files.

Bstat.gz and actdir.gz files (reporting Beacon Status and Active Directory inventory respectively) are generated on the Beacon, but do not leave Incoming\BeaconStatus and Incoming\ActiveDirectory

 

In the %TEMP%\Managesoft\Uploader.log for the account performing our upload, we note:

Uploading file 'x.actdir.gz' to '<Parent Beacon or Application Server URL>/ManageSoftRL/ActiveDirectory'

WARNING : Could not lock local file

Diagnosis:

Open the Windows Task Scheduler on your impacted Inventory Beacon

In the Task Scheduler, navigate to Task Scheduler Library > Flexera Inventory Beacon

Select the 'Upload Flexera logs and inventories' task

 uploadflexeralogs.png

When the actdir/bstat files are generated, they are first placed into C:\Windows\Temp, and compressed in this location

Therefore, the compressed file may inherit C:\Windows\Temp's permissions - leading to issues when the Service Account (potentially without C:\Windows\Temp access) attempts to upload a file.

Solution:

Ensure that the user account specified under 'use the following user account' has Full Control permissions to C:\Windows\Temp

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Version history
Last update:
‎Jul 06, 2020 03:55 AM
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