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Summary

If installation files have been directly downloaded from the Internet and uncompressed then running the Config.ps1 or InstallCognos.ps1 script may fails to an error message like the following:

Could not load file or assemply 'file:///C:\FNMS\Support\DotNetZip.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)
Could not load file or assemply 'file:///C:\FNMS\Support\Ionic.Zip.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)

Cause

Windows can block access to DLL files that it tracks as having been downloaded from an untrusted location.

Resolution

Executing a PowerShell command like the following will use the Unblock-File cmdlet to unblock access to downloaded DLLs (replace the path "C:\FNMS" with the relevant directory path for your environment):

Get-ChildItem -Recurse "C:\FNMS\Support" | Unblock-File

Additional Information

Here are some additional resources that discuss unblocking files in Windows environments:

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austinraun
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Level 3
stefange
By
Level 6

Hi,

Other solution would be to run the unblock-file command in Powershell for the ionic.zip.dll

Stefan

Version history
Last update:
‎Sep 25, 2022 10:59 PM
Updated by: