Symptoms:
A custom report using the 'Cloud instance' node results in missing content unless the admin role or the OOTB Operator Role is given to the FNMS operator.
Diagnosis:
FNMS UI does not allow the CMInventory/list right to be configured on custom roles, so there is no way to create a custom role with the specific right set up (CMInventory).
Solution:
A bug ticket IOJ-2162905 (FNMS-69838) has been raised for this. As a workaround, please keep using a cloned OOTB Operator role for now.