Showing results for 
Show  only  | Search instead for 
Did you mean: 

o365 connector, User impersonation Issue

Hi All,

We have been trying to connect o365 connector via beacon and create power shell based new connection and choose to generate to token and while it points to username,  while we try and key in service account and click next, it tries to impersonate my local/personal e-mail account for some reason.

We tried to update settings on internet explorer(internet options > security settings > custom level > user authentication) from 'anonymous logon' to 'prompt for username and password' but no luck so far.

Let us know if someone has faced this and got this solved. 

(6) Replies


i can't tell you why this happens or why the beacon behaves this way. i have experienced it myself only 1-2 times until now and in other projects there was this error.

The following workarounds helped me

1) Log on to the beacon with your service account and run the o365 setup again. this should use the service account as login

2) Run the beacon service with your service account and run the o365 setup again (If the service is running as SYSTEM)

Best, Dennis

Hi @dennis_reinhardt,
Firstly thanks for the response.
Coming back to solutions proposed, the first one seems may not be possible as most service accounts will non interactive and may not allow logins.
Second one to change system account to service account, I shall this one and update back here.

Nevertheless would try first solution also to see if that allows me to do so.

Hi @savin_shetty1 ,

I have seen this behavior with one other customer. Basically, if you go to or on the beacon machine, it will show you that it is automatically logging you with your personal account. What you can try is ensuring that you log out from those sessions so that when you go back to those sites, it prompts for the credentials. If I remember correctly, the customer who was running into this problem worked with their IT team so that they are not automatically logged in using their personal credentials.

I hope this helps.


@Alpesh we did try logging out from, but no success here.
We also tried to change IE settings in past to prompt for username and password, but does not work either.

@savin_shetty1 : Try this approach:

If the above does not work for you, then check with your IT team. They should be able to help you further.


We tried both of these solutions, Unfortunately our service account being non-interactive we were unable login to server and also unable run Beacon engine service as 'Service Account'.