heiko_fuchs2
Level 4

VMware vCenter 6.7 support with ESXquery

Hello,  

does Flexeras stand-alone inventory tool ESXquery the VMware vCenter Version 6.7 ?

... because in the documentation I found "supporting versions from 5.0 to 6.5 inclusive" ...

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

10 Replies
tschaus
Moderator Moderator
Moderator

Yes, 6.7 is supported. This is just an error in the documentation.

Could you send me the URL to download the newest ESXquery version ?

0 Kudos

Is there a version or timestamp to indicate we are using the latest esxquery.  The version referenced in the Knowledge base is from Oct , 2018 and doesn't seem to work for me on VMWare 6.7.3

 

-- Kevin

*Push*

I have a client asking for 6.7.3 compatibility.

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos

Hi @kevin_christens,

Have you done any further testing with VMware 6.7.3?

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos

I'm also experiencing issues getting inventory from 6.7.3.  I have two VCenters that are 6.7.3 and 5 that are 6.5 and they are working normally. The error I am getting is invalid credentials.

 

Failed to login to web service https://xx.x.xxx.xxx:443/sdk, Message: SOAP fault: Cannot complete login due to an incorrect user name or password

0 Kudos

We found the issue was that after upgrading our beacons to Windows 2019 Server we were successfully able to use ESXquery on vCenters 6.7 and higher due to new policy settings for TLS 1.2 support on the newly updated beacons.  This also meant we could not talk to a few of the older vCenters that did not have TLS 1.2 support from our new Windows 2019 beacons.  We resolved this by building a Windows 2016 Server beacon that had a relaxed policy setting to allow us to inventory  vCenters that failed on the new Windows 2019 Beacons servers with this error:

One or more errors were encountered while retrieving a Secure Sockets Layer (SSL) certificate from the server: The application experienced an internal error loading the SSL libraries.
In fsend call to WinHttpSendRequest: A security error occurred (12175)
An error occured in HTTP processing

Standalone ESXQuery is working fine for us now.

stefange
Level 6

Hi,

I can confirm the esxquery works with vCenter server version 6.7.0 (using esxquery version from 02/10/2018)

Stefan

krunallathiya
Level 2

The upgrade to vCenter Server 6.7 affects other software components of the data center.

Upgrading vCenter Server and Related VMware Products and Components summarizes how upgrading vCenter Server can affect your data center components.

vCenter Server 6.7 can manage ESXi version 6.0 or 6.5 hosts in the same cluster with ESXi 6.7 hosts vCenter Server 6.7 cannot manage ESXi 5.5 or earlier hosts.

vSphere supports upgrades from vCenter Server 6.0 and later to vCenter Server 6.7. To upgrade from vCenter Server 5.0, 5.1, or 5.5, you must first upgrade the vCenter Server instance to version 6.0 or later releases and then upgrade to vCenter Server 6.7. For information about upgrading vCenter Server 5.0, 5.1, or 5.5 to version 6.0 or 6.5, see the VMware vSphere 6.0 Documentation or VMware vSphere 6.5 Documentation.

I hope this helps.

0 Kudos