Showing results for 
Show  only  | Search instead for 
Did you mean: 

Just installed a fresh copy of FNMS 2019 R2 - Page not loading thumbnails

Hello everyone!

We just installed an FNMS 2019 R2 system and everything seems to be working for the most part. The only issue I am seeing is that the thumbnails on the pages are not loading. When I look at the developer section of the browser, I see a bunch of errors relating to the loading of all thumbnails... they are all similar to the following...

Failed to load resource: the server responded with a status of 500 (Internal Server Error)

I have checked the IIS applications to make sure they are running as the service account. I have also made sure that the service account has access to the directory where the files exist. Can anyone tell me what I am missing? I have a ticket in for this, but we are not getting a response back from customer support and we need to resolve this.

Any hello would be greatly appreciated. 




(12) Replies

Have you tried a different browser?


Do any of the following recommendations help?




are you sure its FNMS 2019 R2?



Hi @thomas_dickey,

I assume this happens when you launch the WebUI management page, and you are using our on-premise offering. Let me know if these assumptions do not sound right.

I reckon something has gone wrong at the installation or configuration phase. Since the thumbnails do not load because of 500 Internal Server Error, can you post the WebUI log file? This can be found in C:\ProgramData\Flexera Software\Compliance\Logging\WebUI\webui.log

Keep in mind that the log file may contain sensitive information such as Operator Login Name which can be in the form of a personal email address, so please review and filter sensitive information before you post the log file.

It might also be beneficial to post the full list of errors you see in the browser developer console so we can ensure that there are no preceding errors which could have caused this behavior.

Also as you have an open support question with us, can you post the ticket number?

Cheers, Kent

p.s. 2019 R2 is not released yet, so I believe you are referring to an earlier FNMS version?

@kent-au by the way, are a date set for on-premise 2019R2?
Since the R2 Cloud comes on 17'th of October.

Yeah, sorry about that....


It is 2019 R1. 


I'll check the rest of your recommendations and report back! Thanks folks!

So I have verified that the service account has access to the webUI directory and the files do exist. 

The ticket number is 01924962.

We are supposed to be migrating from our 2017 R3 system to this 2019 R1 system on Thursday. I have been going back and forth with Flexera Support for almost two weeks regarding this and another issue, 01917399. In addition, we have John Jasper as a contact for our account but we are not getting any response from him or from support. We are hoping that we can get on a call with a support rep to resolve these last few issues (I think they will be simple things to resolve) so that we can move forward with our migration on Thursday. 

This is for the State of California, out client... so we really want to make sure that we meet the deadline and provide a clean version of your fantastic system to the State team. 

Please help me to meet this need ASAP. I have included my direct cell number in the tickets so any support rep can reach out to me!

Thanks! I appreciate your time and the great product!


Here is a screen-shot of the site with all the errors. 

No thumbnails.png

Here is the entire contents of the WebUI file...


[INFO 2019-10-07 18:39:39,711 171ms ResolverConfig ] Configuring resolver
[INFO 2019-10-07 18:39:40,477 937ms vicePointManagerHelper ] Security protocols Tls, Tls11, Tls12 are in use.

Hi @thomas_dickey 

I have reached out to our support team and they should get back to you by today or tomorrow. I will unfortunately be on leave from tomorrow, but I'll try to help with what I can here.

For the WebUI log, that's not the correct one. They are rolled over to different files per day, so you should see webui.log, webui.log.10-08-2019, etc.  We want to reproduce the 500 internal server errors and grab the latest webui.log file, or simply check the earlier log files. You should see something like:


[ERROR 2019-10-09 08:32:39,983 22374ms UnhandledErrors                        ]
An unexpected error occurred (ef8a79d2-a122-44bb-ac10-b0f14241884c) System.SomeException: Some exception occured. at ... [ERROR 2019-10-09 08:32:40,297 22688ms ClientErrors ] Client error. [ RequestUID: ef8a79d2-a122-44bb-ac10-b0f14241884c URL: http://localhost/fnms Context URL: /Request/To/MyImage.png Message: Internal Server Error ]

@mag00_75, I believe 2019 R2 on-premise release is scheduled for 05 November 2019.


Cheers, Kent


Thanks for the response Kent. 


It does not look like the errors are making to the WebUI log. The server has not been up for long so I was able to check all of the files and even reproducing the problem and checking the current log is not showing anything. 

Do I need to set WebUI to a higher logging level? I think I recall something like that from troubleshooting the 2017 system.  Is that in the WebUI.config file?

Thanks again for the help!

It's correct that you can change the log level from INFO to DEBUG in the webui.config file, but it won't help in this case as we saw 500 internal server error. ERROR-level log will always be written.

Since nothing appears in the webui log file, the problem is likely at IIS level before the WebUI application gets a chance to handle the request. We'll need to grab the IIS log file, which by default is located in %SystemDrive%\inetpub\logs\LogFiles. You can also see the log file location by going to IIS Manager > Default Web Site > Suite > Logging.

So for example, you may see something like this:


2019-10-09 19:39:47 localhost/fnms GET /suite - 80 - Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/77.0.3865.90+Safari/537.36 - 500 19 13 318

In the case above, it's a 500 internal server error with sub-error code 19 (Configuration data is invalid). See

Also, what's the credentials set in your Anonymous Authentication? Is it IUSR? You can check this by going to IIS Manager > Default Web Site > Suite > Authentication, and right-click > Edit on Anonymous Authentication option.

Cheers, Kent


The latest support response had the solution. I had to add the service account to the local Administrators group as well as the local IUSR  group. I also had to shut off IE Enhanced Security. I tried that and rebooted IIS and still had the trouble, but once I rebooted the server everything was fine. We are off and running!!!


Thanks Kent and others for your assistance with this issue. Very much appreciate your time and efforts!