Some users may have issues creating a community account. For more information, please click here.

gotqcorp
Intrepid explorer

Invalid Tenant Error after trying Inventory File

Hi guys,

I'm trying to import .ndi.gz file with manually shipping from the target machine.

after trying to import, there were and invalid tenant error for system inventory and oracle inventory for specific server. these files were located in the invalidtenant folder under Inventories\badlog.

 

anyone who can help me to solve this problem?

regards,

gotqcorp

0 Kudos
5 Replies
ChrisG
Community Manager Community Manager
Community Manager

Are you working with a multi-tenant system? In that case, the best approach will need to upload the inventory from a beacon associated with the correct tenant: the beacon's identity and way it authenticates during the upload is important for working out which tenant to store the NDI data against. If you just try to place an arbitrary NDI file on the inventory server and import it, there is no way to tell which tenant the data is from and you will get an "invalid tenant" error as you're seeing.
(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
gotqcorp
Intrepid explorer

Dear,
No it's on-premise installation. I didn't set up multi-tenancy.

Regards,
gotqcorp
0 Kudos

@gotqcorp - If you run the following SQL Query against your FNMS Compliance database, what does it return?

SELECT * FROM Tenant

0 Kudos
ChrisG
Community Manager Community Manager
Community Manager

So the "invalid tenant" indication might be somewhat of a red herring - it could mean a different type of failure.

Have you attempted to disable the scheduled task to import these NDI files, and manually run mgsimport.exe from the command line to process them to see what it outputs? (I think you are pretty knowledgeable about FlexNet Manager Suite so likely know how to run mgsimport.exe like this, but if not let us know and I'm sure somebody in the Community can provide some further tips.)

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos
stefange
Active participant

Hi,

I have similar error messages which occur from time to time. Often this happens after an outage of the network and especially when IBM PVU scanning is enabled on vCenters. I checked the Beacon registry settings for a Tenant ID but the field is empty which should be the case as it is a single tenant environment. This environment processes  over 60.000 inventories a day due to vCenter IBM scanning.

Together with support, a dll was modified for extra logging but this did not provide any more information. The case is still open.

Stefan

0 Kudos