Showing results for 
Show  only  | Search instead for 
Did you mean: 

FNMS 2019 R1 install only showing Beacon version available, forcing new Beacon servers to downgrade

Our fresh install of FNMS 2019 R1 is only showing Beacon software 

C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\WebUI\Content\Beacons

Shows the correct version install is available on the Application server which is 

Can someone please help us to figure out how to get the newer version listed in the application so we can update the beacon server?


I am looking at the Beacon properties page and only seeing the older version. 

(5) Replies



You can rerun you config.ps1 with the extension updateConfig, it should resolve that issue


./config.ps1 "config\FNMS Windows Authentication Config.xml" updateConfig

When I run that command I do see where the script is attempting to load the packages, however it errors out with the message below. 

It seems to be unable to see the file. The first time I received this error I went and looked at the path specified and indeed the files where not there. I was able to find the file it is looking for in the C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\WebUI however and so I copied the files into the path below. I still receive the same error however upon re-running the config script. 

Invoke-Expression : Exception calling "LoadFrom" with "1" argument(s): "Could not load file or assembly
'file:///C:\Program Files (x86)\ManageSoft\WebUI\bin\Ionic.Zip.dll' or one of its dependencies. The system cannot find
the file specified."
At C:\temp\FlexNet Manager Suite\support\ConfigHelper.ps1:590 char:12
+ $ret = Invoke-Expression "$exe $params"
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Invoke-Expression], MethodInvocationException
+ FullyQualifiedErrorId : FileNotFoundException,Microsoft.PowerShell.Commands.InvokeExpressionCommand

Hi Thomas,

Did you get any resolution for this error, i am also facing exactly the same while repointing to a new database.

Looking at the stack trace I see the script detects the installation directory as C:\Program Files (x86)\ManageSoft\ when it should be C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform.

Please look in the registry under the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ManageSoft Corp\ManageSoft

and ensure the values for ComplianceInstallDir, ETAPInstallDir, and InstallDir correctly points to the FlexNet Manager Platform directory where you have FNMS installed.

And also the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Flexera Software\FlexNet Manager Platform

should have FNMPInstallDir pointing to the same path

ie. by default, these should all point to C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\ or wherever the installation actually exists.


As to how this happened, did you have the agent or some other older component installed on the machine at some point?  My guess is that those pointed towards the old format of the path or if you installed the agent afterwards, that has a tendency to overwrite InstallDir.

(Anything expressed here is my own view and not necessarily that of my employer, Flexera)
If the solution provided has helped, please mark it as such as this helps everyone to know what works.