Showing results for 
Show  only  | Search instead for 
Did you mean: 

Custom Location Import

I'm currently trying to do an import of custom location names via business adapter for flexera on prem. When trying to import the location names I am putting a / in the sub-level path, however, after being imported none of the locations are showing up nested. I can't do a bulk  sql insert even though I am db owner. I've also tried nesting the location names in the csv itself. Anybody have experience with this?

(14) Replies

Hi Stefan,

For the locations, make sure you are providing the full path with a leading slash, please.

I'm assuming that your data source looks like the following example CSV file, using a leading forward slash ('/') for the location path.

/Test/Sublocation A
/Test/Sublocation B

When configuring the 'Name' target property of the 'Location' target object in Business Adapter Studio, make sure that in the 'Data Transformation' section, you have the forward slash ('/') character configured in the 'Split values on' configuration field please:


 When importing your source data, Business Adapter Studio will create a location 'Temp' in the root, and 'Sublocation A' as well as 'Sublocation B' als children of the 'Temp' location.

Thank you this looks really helpful. I will give this a shot when I have time later this morning. 

I had the same results with this, although it did update the description of the top level with a value from one of the sub-levels. Would you recommend making a field of arbitrary values for 'ID'? Not sure what the source value for that field should be. 

Hi Stefan,

  • Leave the 'ID' field on it's default auto-generated value 'Location_ID', please.
  • Make sure that your data source has a column that includes the full path of your target location using a forward slash ('/') as the path separator, like in the '/folder1/folder2/folder3' example.
  • Make sure the forward slash ('/') is configured in the 'Split values on' field.

That should be it. When importing the data, any level of the '/folder1/folder2/folder3' path that does not exist yet will be generated.





I believe my name location is correct. The ID field has a 'row number' option, but when selected it doesn't successfully run a query to Flexera.

@StefanGrisham - Do not assign a value to the ID field, Flexera will set that automatically.  Just leave it blank.

Hi Stefan,

  • In Business Adapter Studio (MGSBI), when creating a new target object of type 'Location' (Context menu: Add New Item > Enterprise Groups > Location), MGSBI will create a new 'Location' target object. The 'ID' property of this object will be populated automatically with a value of 'Location_ID'. Leave it as it is.


  • The configuration of the 'LocationName' field in your screen shot looks correct

There is nothing else to configure. Just import your source data.



Even, I'm working on similar requirements but still, the location is not created with a proper
hierarchy.  I'm uploading two locations /INDIA/CITY, TOWER 2/SOUTH/6/S6-319/ and /INDIA/CITY, TOWER 2/SOUTH/6/S6-320/ but it creates a single record for each level and it doesn't nest.

I'm attaching a screenshot of my adapter configuration and the output of the web UI





In the Data Transformation section, did you make sure the forward slash ('/') is configured in the 'Split values on' field?

Yes I did it but still same

I think I could simulate your issue. I see from your screenshot that the "ID" under location is not set.

In contrast, when I create a fresh Business Import, it looks like this:


With this in the import, it works just fine:

Screenshot 2023-07-27 113626.png

Do we need to provide the ID? I understood from earlier conversations that we need to keep it as empty, 
If yes, then is it random value?

You don't need to provide any data for that ID field, it is working as it is. I am not exactly sure what the inner workings are regarding that field.

Thank you, The following mapping worked for me