cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
hailstorm
Pilgrim

Admin server- Failed to invoke the API via servlet. agent not registered

Jump to solution
I am trying to get FlexNet Manager for Engineering Applications 2016_R2 working on a Centos 7.x machine. This machine has the license manager for the monitored product, as well as the Flexnet agent, administration server and reporting server. The backend oracle database is on a separate server.

The partial admin server config follows


http port: 8888
Jboss Mgmt port: 9974

service user name: root


Secure server settings
HTTPS port: 8444
key store path: /opt/FLEXnet/manager/admin/site/bin/keystore
keystore pw:

truststore: /opt/FLEXnet/manager/admin/jvm/lib/security/cacerts
truststore pw:

Database Server
DB type: Oracle
DB server host: db1.mydomain.com
DB Server port: 1521

Flexnet Database:
database service name: dbflexadmin
db user: xxxxx
db password: (all caps)
table space: SYSTEM


Reporting server:
reporting server name: localhost
reporting server https port: 8453




The reporting server partial config:

HTTP Port: 8898
Jboss Mgmt port: 9984
Svc user name: root



Secure server settings
HTTPS port: 8453

key store path: /opt/FLEXnet/manager/reporting/site/bin/keystore
keystore pw:

truststore: /opt/FLEXnet/manager/reporting/jvm/lib/security/cacerts
truststore pw:


DB Server
DB type: oracle
DB Server host: db1.mydomain.com


Flexnet Database:
database service name: dbflexreport
db user: FLEXNET
db password: (all caps)
table space: SYSTEM




Admin server
Admin server name: localhost
admin server https port: 8444





I followed the instructions on how to trust the default certificate bundled with Flexera.


As you can see , the admin server is using port 8444 while expecting a reporting server on 8453. The reporting server is running on 8453 and expecting an admin server on 8444. The administration server log generates "Failed to invoke the API via servlet" errors. (which implies a mispatch in port configuration between the admin server and reporting server but I can't find any problems.)

I can login to the administration page via http://xxxx:8888 or https://xxxx.8444. But I do not see any agents registered.


The agent is configured with following settings

broker protocol: tcp
broker hostname: 0.0.0.0
broker port: 61616
http upload protocol: http
http upload hostname: thisserver.mydomain.com
http upload port: 8888
secure broker: not set




I am unsure if the agent issue is related to the " Failed to invoke the API via servlet" error? I am also unsure how the agent is supposed to register itself with the admin server - is it using the upload port or the broker port?


Thanks
0 Kudos
1 Solution

Accepted Solutions
stefangeerars
Occasional contributor

Re: Admin server- Failed to invoke the API via servlet. agent not registered

Jump to solution

Hi,

Problem occurs when replacing the "default" tomcat alias from your keystore with your own trusted certificate. When replacing the tomcat alias from the keystore, the admin server does not trust the reporting certificate.

You must import the certificates of the admin and the reporting server (including the certificate chain) in the cacerts file as trusted certificates.

/opt/FLEXnet/manager/admin/jvm/lib/security/cacerts

/opt/FLEXnet/manager/reporting/jvm/lib/security/cacerts

The problems with the agents seems not to be related to the "Failed to invoke the API via servlet"

These steps are missing from the installation manual

Stefan

View solution in original post

3 Replies
Liz_Best
Pilgrim

Re: Admin server- Failed to invoke the API via servlet. agent not registered

Jump to solution
Hi,

Would you review the following article to see if it offers any clues to assist you in resolving this issue?

https://flexeracommunity.force.com/customer/articles/en_US/ERRDOC/Error-java-lang-NullPointerExcepti...

Regards,
Liz
0 Kudos
hailstorm
Pilgrim

Re: Admin server- Failed to invoke the API via servlet. agent not registered

Jump to solution
Yes, I have seen that document.

The admin server runs on https port 8444 and looks for a reporting server on localhost https port 8453.
The report server runs on https port 8453 and looks for a reporting server on localhost https port 8444.

So I think there is a problem somewhere else.

Thanks
0 Kudos
stefangeerars
Occasional contributor

Re: Admin server- Failed to invoke the API via servlet. agent not registered

Jump to solution

Hi,

Problem occurs when replacing the "default" tomcat alias from your keystore with your own trusted certificate. When replacing the tomcat alias from the keystore, the admin server does not trust the reporting certificate.

You must import the certificates of the admin and the reporting server (including the certificate chain) in the cacerts file as trusted certificates.

/opt/FLEXnet/manager/admin/jvm/lib/security/cacerts

/opt/FLEXnet/manager/reporting/jvm/lib/security/cacerts

The problems with the agents seems not to be related to the "Failed to invoke the API via servlet"

These steps are missing from the installation manual

Stefan

View solution in original post