Summary
When trying to import the default packages to IBM Cognos Analytics, it wait with "Unable to connect to remote server" message.
Symptoms
During IBM Cognos Analytics installation, the final step is to import the Sample Reports through a the CognosPackageImport.exe import utility.
After specifying the Cognos Server and clicking "Install Report Package," the windows immediately displays the following:
Publishing package...
Logging in to Flexera Report Designer (powered by Cognos)...
ManageSoft.Compliance.ComplianceException: FlexNet Manager Platform was unable to log in to the Cognos server. Please make sure that the Dispatcher is up and running at http://CognosServerName:9300/p2pd/servlet/dispatch and that it is configured correctly. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.1.101.76:9300
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
--- End of inner exception stack trace ---
at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
at System.Net.HttpWebRequest.GetRequestStream()
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Flexera.CognosPackageImportLogic.CognosConnection.Login(String login)
--- End of inner exception stack trace ---
at Flexera.CognosPackageImportLogic.CognosConnection.Login(String login)
at Flexera.CognosPackageImportLogic.CognosConnection.ImportPackage()
at Flexera.CognosPackageImport.CognosPackageImportMainForm.b__2()
at Flexera.CognosPackageImport.CognosPackageImportMainForm.b__8()
Cause
Importing sample report packages requires access to Cognos' internal Dispatcher web service which runs on port 9300 by default.
The above error occurs when either a software or hardware-based firewall blocks the connection.
Resolution
Opened TCP Port 9300 communication from the FlexNet Manager Suite Batch/Application Server towards the Cognos Analytics Server, making sure the Windows Firewall and any network firewalls have this port open.