cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

AppPortal is not showing as registered with Flexera Gateway Services

Jump to solution

I installed AppPortal 2021 R2 on a new Windows 2019 Server along with Flexera's Gateway Service but AppPortal is not displayed as one of the services:

All I see is the FlexNet 

 Following services are currently registered with Flexera Service Gateway

  • FlexNet Manager Suite On-Premises [Flexera Suite servername]

I expect to see both FNMS and AppPortal displayed:
Following services are currently registered with Flexera Service Gateway

  • App Portal [AppBroker servername]
  • FlexNet Manager Suite On-Premises [Flexera Suite servername]

I am unable to figure out from the documentation how to register AppPortal with the Gateway, even though it is able to show what the Gateway is registered for.  Seems like AppPortal would not be able to show what is registered with the Gateway if it was not registered with it.

Anyone have ideas?
Thanks

0 Kudos
1 Solution
CharlesW
Level 11 Flexeran
Level 11 Flexeran

I believe that App Broker should register itself automatically, once you enter a value for "Flexera Service Gateway Server Name" (under Settings->Flexera Integration), and then save your settings. If there is a problem, I'd expect something similar to the following to be logged in the log file named GlobalConfig.log:

Could not register App Portal Service <FSGName> with Flexera Service Gateway. Message <message>

Perhaps it's simply a refresh issue.. Assuming that you have entered a value for ""Flexera Service Gateway Server Name", try peforming an iisreset to see if it shows up.

 

View solution in original post

3 Replies
CharlesW
Level 11 Flexeran
Level 11 Flexeran

I believe that App Broker should register itself automatically, once you enter a value for "Flexera Service Gateway Server Name" (under Settings->Flexera Integration), and then save your settings. If there is a problem, I'd expect something similar to the following to be logged in the log file named GlobalConfig.log:

Could not register App Portal Service <FSGName> with Flexera Service Gateway. Message <message>

Perhaps it's simply a refresh issue.. Assuming that you have entered a value for ""Flexera Service Gateway Server Name", try peforming an iisreset to see if it shows up.

 

Thank you Charles.  We had previously just used 'localhost' for the gateway since it is running on the same server as AppPortal.  We are still running FSG on the same server as AppPortal and it did see the settings for FNMS but did not self register until I set the name to the actual servername.  We are using CNAMEs instead of physical servername so maybe that adds complications.

It seems to be working as expected now.

0 Kudos

CNAME records versus A (host) records shouldn't matter, and localhost should still work.  The name you enter is all about name resolution/finding an IP address.  For that matter, you could even enter the IP address (either assigned or loopback - 127.0.0.1).  Basically, anything that will resolve an IP address that can be reached from your App Portal server should work.  If one of those options doesn't work, even though you can resolve it to an IP address, then there may be some network/local firewall restrictions preventing the traffic on the necessary ports.

Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".
0 Kudos