Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem installing and starting service in Repackaged MSI

I have a vendor setup that installs a service as part of the setup.
The setup extracts an MSI, which I first tried to use with tuner. This MSI will not attempt to install the service and the application cannot start because of it.

I broke down and tried to use Repackager 9.5 in both monitoring and snapshot mode. Was able to find the component that installs the service. However, I get the following error in event viewer when trying to isntall the repackaged MSI and start the service using an Admin account on the workstation.
Error 1920.Service CentralDICOMServer (CentralDICOMServer) failed to start. Verify that you have sufficient privileges to start system services.

If I set this to not start during the install, it will complete, but still wont run. I did a msi install log detailing whats happening which doesn't seem to tell me much (see attached). What am I missing?

Thanks in advance.
(3) Replies
The 1920 error unfortunately does not narrow down the cause of the failure with starting the service. Here are some things you can look into to try to get to the bottom of this:

1. Check the ServiceInstall and ServiceControl tables in the built MSI. Compare with the documentation for these tables and also check to see if these tables were being used in the original install (before repackaging) to see how they were populated before.

2. Verify that all dependencies for the service EXE (CentralDICOMServer.exe) are present.

3. Verify that the correct internal name of the service (not necessarily the display name) is being used as the key of the Service* tables above.

4. Try to remove the ServiceControl table entries, then install the MSI, and then manually try to get the service to start-up successfully. Once you determine what the problem was, then you can correct it in the MSI (you could use ProcessMonitor, do a file diff with the original install, etc).

Hope this helps!
Hi Ajay,
i am having a problem getting my services to start on a Vista machine, whereas they ran fine on the XP machine that i developed them on. The MSI installer errors out when it is on the screen where there is the "Starting Services" progress bar. It says that same error 1920 about not having privileges to start the service. i know this is not the case because i have it running in administrator mode. I am needing to know what needs to be changes between these two operating systems, what do i need to add that didnt need to be there when starting services on XP?

Please let me know if you are aware of anything that i can add that will enable the services to start on vista! thanks!

I am not aware of any settings that need to be changed for the service to successfully install and start on a Vista machine when it already works on a XP machine.

I am inclined to think that this is a problem specific to your service. I suggest you try the general troubleshooting steps I outlined before such as removing the service start-up logic in the install, install it on Vista, and then go into the service manager and try to start the service.

Also take a look at the Windows Installer reference for the relevant tables to see if it helps you to spot anything.

ServiceInstall Table

ServiceControl Table