Showing results for 
Show  only  | Search instead for 
Did you mean: 

AdminStudio Quicktime

Worked through my earlier hurdles and finished my repackaging of Quicktime 6.5.2. I tested it thoroughly on a couple computers as an admin and a user and it worked fine. We started testing on a small OU with about 15 computers.
The install goes fine, however when a user logs on and tries to open either a .mov or a streaming file quicktime goes to configure itself for the first time, crashes and closes. The error message is Quick TimePlayer.exe has generated errors and will be close by Windows. You will need to restart the program. An error log is being created. This does not take place if an Administrator logs on and it does not take place if a user logs on after an Administrator who has logged on and ran quicktime. So logic says there is something in group policy that is causing a problem with Quicktime the first time it is run and tries to configure itself.

Quicktime is being installed to C:\Program Files\Quicktime and is being delivered via group policy using the system account.

Also I'd love to know where this mysterious error log is written.

Steps I have taken:
Run file and regmon and it seems that Quicktime is trying to access HKCU

The group policy issue I am sensing is that when the user logs on for the first time there is either a file or registry entry that Quicktime tries to write the first time it is run and that is the only time it is run. Logic poses that Group Policy is stopping this key or file being written as Quicktime tries to write I'm guessing configuration after being started for the first time.

Has anyone else seen this or is anyone else familar with this.
By the way the version of Quicktime is 6.5.2

(3) Replies
If you have AdminStudio Professional Edition you can use Quality Monitor to run a locked down environement test. Quality Monitor will tell you which registry entries QuickTime is trying to write to without proper permission.
Tried using Quality Monitor and did not really see a definitive answer.
David ran quality monitor on one of the boxes that Quicktime was going to be installed on. When I tried to run the Lockdown tests I got an InjectLibrary failed GetLastError=5. Don't understand why I'm getting this, and found nothing in the knowledge base about it.