Highlighted
Flexera beginner

CSI-Agent and use of proxy via WPAD not possible?

Jump to solution

Hi.

I just recognized that the running csi-service is not working without the direct input of our proxy in the installation file. In logfile it says:

Connection error....
Error while checking in with server (12002) : "Das Zeitlimit für den Vorgang wurde erreicht." (timeout reached)

We are using WPAD-configuration in our network for a couple of months now and most software and services work okay without configuring a proxy server in their configuration anymore. And in the next couple of weeks we will change the proxy which is used by now.

So my idea was to roll out a new CSI-client without the proxy config. And now I recognized the error.

Does it mean, csi-agent needs a hard coded proxy in its config?

But how do you solve the problem with laptop-users? in domain network proxy has to be active and in other networks it should work without a proxy. Or better it recognizes, if the network delivers a proxy entry e.g via WPAD.

What do I miss here?

Will roll out a new client-agent again with proxy-settings.

Thx in advance for suggestions.

Greatings from Germany.

Martin

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Flexera
Flexera

Re: CSI-Agent and use of proxy via WPAD not possible?

Jump to solution

HI Martin,

Thank you for posting in the customer community.

The CSI agent does not currently support Web Proxy Auto Discovery Protocol, you will have to deploy a new agent to the client machines with the proxy configured.  The link below shows how you add the proxy during the creation of the Agent Deployment Package.

https://docs.flexera.com/csi/Content/helplibrary/Add_Proxy_Settings.htm#svm_cloud_edition_patching_4...

Regards

Simon Edwards
Senior Technical Support Engineer
SVM Support

Simon Edwards
Senior Technical Support Engineer
SVM Support

View solution in original post

2 Replies
Highlighted
Flexera
Flexera

Re: CSI-Agent and use of proxy via WPAD not possible?

Jump to solution

HI Martin,

Thank you for posting in the customer community.

The CSI agent does not currently support Web Proxy Auto Discovery Protocol, you will have to deploy a new agent to the client machines with the proxy configured.  The link below shows how you add the proxy during the creation of the Agent Deployment Package.

https://docs.flexera.com/csi/Content/helplibrary/Add_Proxy_Settings.htm#svm_cloud_edition_patching_4...

Regards

Simon Edwards
Senior Technical Support Engineer
SVM Support

Simon Edwards
Senior Technical Support Engineer
SVM Support

View solution in original post

Highlighted
Flexera beginner

Re: CSI-Agent and use of proxy via WPAD not possible?

Jump to solution

Hi Simon.

I will also answer to the ticket which was opened about my question.

I know how to add the proxy in the config file. We used that for a couple of years now. But after implementing WPAD I really hoped I could get rid of these manual entry.

I think there are other options next to WPAD to announce a proxy server in a network. Does the agent support any other technic for such scenario?

Why I want no proxy entry in the CSI-Agent config? Cause we have a couple of laptop users who are not very often in our network. And so a proxy entry in the CSI-config will not work on the road.

In the past I used a login script checking for our domain controller. And if not found, the regkey for using the proxy would be changed. If dc is found the key had to be changed back to proxy-use. Not very comfortable but it worked.

VPN is coming soon, so maybe then there will be no problem if we have to use proxy in csi-config.

I hope this thoughts are understandable 🙂

thx,

Martin

0 Kudos