The Community is now in read-only mode to prepare for the launch of the new Flexera Community. During this time, you will be unable to register, log in, or access customer resources. Click here for more information.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Summary

Inventory gathering ndtrack processes on Unix-like operating systems may hang while attempting to gather Java version details if a file named "java" that is not executable is found on the filesystem.

Symptoms

When this issue occurs, output in the tracker.log file from the ndtrack process will stop after logging that looks like either of the following:

[Wed 05 Jan 2022 10:05:28 AM -03 (G, 0)] {17500} The file '/usr/java/jre7/bin/java' has been detected as a possible package registry
[...]
[Wed 05 Jan 2022 10:05:41 AM -03 (G, 0)] {17500} IBM MQ inventory was unsuccessful either because it is not installed or there was an error.

Or:

[Wed 05 Jan 2022 10:05:28 AM -03 (G, 0)] {17500} The file '/usr/java/jre7/bin/java' has been detected as a possible package registry
[...]
[Wed 05 Jan 2022 10:05:41 AM -03 (G, 0)] {17500} Java product: "Java(TM) SE Runtime Environment", full version: "8.1.037", publisher: "", install location: "/usr/java/jre8/bin".

Cause

This issue is caused by a failure by the ndtrack process to handle files name "java" on the filesystem that cannot be executed.

In particular, log message(s) in the tracker.log file stating:

The file '<path>/java' has been detected as a possible package registry

will identify a <path> that does not appear in a subsequent log message:

Java project: <details...>

One of the java files thus identified will be triggering this issue.

Workaround

The inventory agent can be configured to avoid attempting to gather Java version details (and therefore avoid this issue) by setting the tracker component's PerformJavaScan preference to false.

This issue will also not occur if file scanning of directories that contain a problematic java executable is not performed. For example, this could be achieved by configuring the tracker component's ExcludeDirectory preference.

Additional information

Also see the following known issue which has similar symptoms but a different root cause: Inventory gathering process may terminate on Unix-like operating systems while gathering Java version details (IOJ-2241253)

Fix status

This issue has been fixed in the following FlexNet Manager Suite releases: 2019 R2.2 / Mar 2020 (Cloud), 2020 R1 (On Premises)

Other information

Affected components: Agent, Inventory

Master issue ID: IOJ-2072459

Also known as: FNML-67997

No ratings
Comments
Ronny_OO7
By Level 8 Champion
Level 8 Champion

HI can this article please be updated? With ManageSoft Inventory agent 17.0.1' the issue is still present

ChrisG
By Level 20 Flexeran
Level 20 Flexeran

@Ronny_OO7 - the specific bug in the code that was root cause of this known issue is not present in the 17.0.1 agent. Is it possible that the issue you are seeing is the known (but currently unfixed) issue linked from the "Additional information" section of this article?

It is also possible there is another (unknown) issue with similar symptoms - the symptoms described in this article could potentially have other root causes. If you are encountering symptoms like described with the 2021 R1 (17.0.1) agent that aren't otherwise explained then I'd suggest raising a case with Flexera Support so that they can be investigated.

Version history
Last update:
‎Jun 12, 2022 03:52 AM
Updated by:
Knowledge base article header content