cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Summary

The Error "SoapFaultCode:5 System.Web.Services.Protocols.Soap" when starting ""/LICMAN/START" within SAP.

Symptoms

When running "/LICMAN/START" from within the SAP Admin Module the following error message can be seen at the bottom of the SAP window. You may also notice that Pending recommendations are not received from FNMP in even though these have been sent from FNMP without any error messages displayed.

Error Message Displayed:
User-added image

Cause

This error is caused by the "LandscapeUID" used by FNMP not matching the ID used by SAP, this could of been caused by pointing a new FNMP system to a previously installed SAP system for example. The following steps can be followed to identify if this is the cause of the issue.


Locate the FNMP LandScapeUID:
  1. Open a web browser and go to the following URL to access the SAP Web Services "http://<FNMP_HostServer>/SAPService/SAPService.asmx."
  2. Select the "GetAllActiveSAPLandscapes" Web Service and select "Invoke".
  3. Make a note of all the "Landscape_uid" values. A default example is: "DEFAULT_SYSTEM_LANDSCAPE_{D21761EE-3108-43CE-A2A9-7B8C2B217794}"

Locate the SAP LandScapeID:
  1. Within the FNMP SAP Admin module enter "/nse16" into the search box on the top left.
  2. Enter "/LICMAN/MS_PESYL" into the "TableName" search field and run this to load the table.
  3. Select "Settings", "User Specific" settings from the menu bar and load the "Data Browser" tab .
  4. Under the "Output List" section select "AVL List" and select the green tick.
This should now display the "SLUID" used be SAP and these should match the above values from FNMP, if these do not match the issue is present.

Resolution

The error can be resolved by resetting the system landscape and re-importing the FNMP transports. Before doing this please ensure you have a backup of the FNMP and SAP systems.

Steps to reset the FNMP for SAP Landscape:
  1. Run "/LICMAN/START" to load FNMP for SAP.
  2. Select "Administration" from the center pane and "Product License" from the drop down.
  3. From the "License Overview" screen select "Extras" and "Reset Sys .Landscape", select ok on the dialog and return to the screen in step 1.
  4. Re-import the SAP system landscapes by selecting "Import System Landscape" and save the RFC destinations on the next dialog.
  5. Re -run "/LICMAN/START" and you should no longer see the error message.

Additional Information

Additional information on importing the transports can be located in the FNM_SAP install guide.
Was this article helpful? Yes No
No ratings
Version history
Last update:
‎May 25, 2018 02:11 AM
Updated by: