Summary
This KB article helps to resolve the issue - ComplianceUpload process fails to upload third-party data with "404/Not Found" messages
Symptoms
When FNMP 9.2 is installed and configured on Windows Server 2003 with IIS6, all uploads from the third-party inventory component to FNMP fail.
In the %ProgramData%\Flexera Software\Compliance\Logging\ComplianceUpload folder, the upload.log file shows the failures for each file that are similar to: "Upload package failed, retrying in x seconds (error: Request failed: (404/Not Found) Not Found)"
Also:
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opening the Inventory Beacon program from the Start Menu does not report any issues with configuration download.
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The Test and Download buttons on the Settings tab of the Inventory Beacon program report success.
Cause
IIS6 requires a wild-card mapping for .NET 4.0 in order to work with the third-party inventory features of FNMP 9.2.
Resolution
The fix for this issue requires a configuration change to IIS. Ensure that you have a working backup before making changes.
Use the following instructions in order to resolve the issue.
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Open Internet Information Services (IIS) Manager
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Expand the Web Sites folder in the tree on the left, then expand the Default Web Site. Right-click on the inventory-beacons folder and choose Properties.
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On the Virtual Directory tab, in the bottom right region of the tab, click the Configuration... button. This will show the following dialog.
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Double-click the application extension mapping for the .asax extension and copy the executable path from the resulting dialog to the clipboard. This will be similar to "C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll". Click Cancel.
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Back in the Application Configuration dialog, click the Insert... button alongside the Wildcard application maps list.
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Paste the executable path copied previously into the the Executable text box. Ensure that the Verify that file exists checkbox is cleared. Following is a screenshot showing the required state of this dialog.
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Click OK as necessary to dismiss the open dialogs.
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Restart IIS.
Related KB Articles
Q210696