cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Summary

After upgrading to FlexNet Manager Suite 2015 R2 SP3 Citrix XenApp inventory fails to import

Symptoms

Failure to import Citrix XenApp inventory.
The inventory from a beacon that takes the citrix information from the staging database files with an error similar to:
System.Data.SqlClient.SqlException (0x80131904): Invalid object name 'dbo.ImportedRemoteApplication'.

Cause

The Citrix XenApp adapter has been significantly updated in FlexNet Manager Suite 2015 R2 SP3.
Continued inventory import of Citrix XenApp requires upgrades to:

  • FlexNet Manager Suite Application Server
  • XenApp Server adapter
  • Staging Databases
  • XenApp Server agent

Any previously imported inventory is unchanged, so information displayed in FlexNet Manager Suite is correct at the time of the last import.

Resolution

1.FlexNet Manager Suite Application Server & XenApp Server adapter

  • FlexNet Manager Suite Cloud - the upgrade to the Application Server occurs automatically as part of the release of FlexNet Manager Suite 2015 R2 SP3.
    As soon as the upgrade of the central Application Server is complete, your local inventory beacons are automatically updated with the latest version of the XenApp Server adapter.
    NOTE: The import of XenApp data from the previous version of the XenApp Server agent, using the previous staging database, ceases to operate when the XenApp Server adapters are updated on your inventory beacons.
  • FlexNet Manager Suite On-premise ? this update is performed during the upgrade of the Application Server. Inventory beacons are automatically updated with the latest version of the XenApp Server adapter after the upgrade of the Application Server.

2.Staging Databases

Any staging databases for XenApp inventory must be migrated. The migration script (SetupXenAppAgentStagingDatabase.sql) is contained in the XenApp Server Agent which is included in the ?Adapter Tools for FlexNet Manager Suite? download.

  • FlexNet Manager Suite Cloud - this archive file can be downloaded from the Customer Community Knowledge Base article Adapter Tools for FlexNet Manager Suite.
  • FlexNet Manager Suite On-premise ? this archive file is listed with the product downloads in the Product and Licensing Center, or can be downloaded from the Knowledge Base article listed above.

Note: The staging database table name has been changed from ?XenApp? to ?Remote?.

3.XenApp Server agent

The XenApp Server agent, installed on the XenApp server, needs to be updated. The XenApp Server agent is also included in the ?Adapter Tools for FlexNet Manager Suite? download.

  • FlexNet Manager Suite Cloud - this archive file can be downloaded from the Customer Community Knowledge Base article Adapter Tools for FlexNet Manager Suite.
  • FlexNet Manager Suite On-premise ? this archive file is listed with the product downloads in the Product and Licensing Center, or can be downloaded from the Knowledge Base article listed above.

 

Related Documents

The Release Notes for FlexNet Manager Suite 2015 R3 have been updated with the information (above). This update is available from the Customer Community Knowledge Base article FlexNet Manager Suite 2015 R2 SP3.

Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Apr 04, 2019 02:58 PM
Updated by: