Some users may experience issues accessing the case portal. For more information, please click here.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

FlexNet Manager for Engineering Applications with Oracle 12 backend

Trying to install FlexNet Manager for Engineering Applications on Linux (CentOS.) I am configuring the database backend to point to an existing Oracle 12 server. I temporarily installed Oracle 12 on the same server.

I created a "flexera" database on the same machine , and (with some tinkering) was able to run the "flexnet loaddb" command for the administration server.

Fexnet seems to have some older libraries for communicating with Oracle, I had to add the following line in in sqlnet.ora on the oracle server to allow connections from oracle clients prior to version 12.


I also had to use all-CAPS in passwords, since it looks like the client would automatically convert any password to upper case.

Then as I worked thru the install I saw that the reporting backend needed its own database. Additionally, the cost of Oracle DB licenses is pretty high, so decided to use an existing Oracle 12 Database Server for the backend. I created separate "flexera_admin" and "flexera_report" database instances. I can use sqplus (command line) and Oracle SQL Development Studio to verify that the user name and password is valid. But the "flexnet loaddb" command fails to authenticated.

Anyone else using Oracle backend who may be able to shed some light?

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

1 Reply

With admin and reporting server, the "flexnet site" command has you specify a username and password for access to the database. In this case, I chose a username "FLEXNET." The "flexnet loaddb" command prompts you for a database admin user name (typically "system.") I thought the "system" user login was failing. However when I enabled auditing on the database server it showed that the "FLEXNET" login was failing (presumably after the "system" login succeeded.) In my initial test database, I had created a "FLEXNET" user with the DBA role (probably way overkill.) However I though the the "loadb" command would create the FLEXNET user- and this was not the case. Once I created the FLEXNET user in the databases, the "flexnet dbload" commands worked AOK.
0 Kudos