Showing results for 
Show  only  | Search instead for 
Did you mean: 

Few Business adapter rules are not working


we've a business adapter running with  10 SQL rules to process and insert data to a staging tables. From past few days few rules are not working as they are expected to work but when i run the same query from Sql Studio, it's working fine and even when i select the import option from business adapter, it's working fine.
what could be the issue? 


(3) Replies
By Community Manager Community Manager
Community Manager
Could you elaborate a little on specifically what isn't working? For example - are the SQL queries failing with an error? Are they making different updates to data from what you expect? Is anything shown in the business adapter log related to the queries (enabling "debug" logging will show the most details)?
(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

The SQL query should select data from various tables  and then insert data to staging table where the Business unit = 'ABC'. So it's doesn't insert data to staging table when it's  scheduled but when i run it manually it works fine.


can you share screenshot from beacon application for inventory system page