cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Creating Compliance database 2020 R1 - getting error running ComplianceProcedures.sql

I'm currently installing a clean 2020 R1 instance for testing.

When running the ComplianceDatabasecreation.xml getting an error with ComplianceProcedures.sql at 93%

There was an error while attempting to run 'ComplianceProcedures.sql'

Maximum stored procedure, function, trigger, or view nesting level exceeded (limit 32)

Any ideas out there?

Thanks

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

6 Replies

Log file has "Force the trigger to run on pre-populated data"
UPDATE Currency_MT SET CurrencyCode = CurrencyCode

If I execute UPDATE Currency_MT SET CurrencyCode = CurrencyCode
I get
Msg 217, Level 16, State 1, Procedure Trackchanges_Currency, Line 1 (Batch Start Line 0)
0 Kudos

I have a record of seeing this during one other FlexNet Manager Suite upgrade ~4 years ago. As far as I can see a root cause/reason for the failure was not identified, but the following steps were followed to workaround the error:

  1. Comment out the following line where it appears in the SQL script that failed:
    UPDATE Currency_MT SET CurrencyCode = CurrencyCode
  2. Re-run the database migration step
  3. Once the database migration has successfully completed, manually execute this SQL statement against the compliance database:
    UPDATE Currency_MT SET CurrencyCode = CurrencyCode
(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

Hi,

Commenting out the line has allowed me to complete the database stuff.

However when I try and run the command I get the same error.

On checking the Currency_MT table there are a couple of errors

on the Swedish Krona line and  the Vietnamese Dong the fields from the LongPrefix column have merged with the LongSuffix

and the ShortPrefix has moved across to the ShortSuffix.

Trying to update these fields also gives me the same error

Thanks

0 Kudos

@Smitty987 

If you're still having issues with this I would recommend that you create a support case to get assistance in troubleshooting it and getting it remediated.

Thanks,

0 Kudos

Further update - I had the same "Maximum stored procedure, function, trigger, or view nesting level exceeded (limit 32)" error when running the AD import and it would appear that the issue is caused when "Recursive Triggers" is enabled in the database.

0 Kudos