Some users may have issues creating a community account. For more information, please click here.

jean_martel
Active participant

Configuring Analytics .\installCognos.ps1

Jump to solution
Hi,

When I run this command .\installCognos.ps1 I am getting this message: Installation/configuration of Cognos Analytics server requires a SQL Server at 'ServerName' to be accessible, and the database 'ContentStore' to exist. You may need to enable the TCP/IP Client Protocol.­

After verification, everything is there, SQL server is accessible, there is a ContentStore DB and TCP/IP is enable. I also verified the CognosConfigProperties.xml , everything looks fine

Does someone could have suggestion about this? Thank you

0 Kudos
1 Solution
ChrisG
Community Manager Community Manager
Community Manager

Are you looking to have Cognos use Windows Authentication or SQL Authentication to authenticate to the database?

If you are seeking to use Windows Authentication, this message likely indicates that you a username and/or password configured in the ContentStoreDatabaseUsername and ContentStoreDatabasePassword settings in your CognosConfigProperties.xml file. These settings should be blank if you intend to use Windows Authentication.

If you are seeing to use SQL Authentication, this message indicates a connecting using the credentials configured in the CognosConfigProperties.xml file could not be completed. Try copying and pasting the following commands (replacing "ServerName" and "ContentStore" with your actual server and database names respectively) into your PowerShell window:

$c = Get-Credential

$ConnectionString = "Server=ServerName;Database=ContentStore;User ID=$($c.UserName);Password=$($c.GetNetworkCredential().Password);"

$sqlConnection = New-Object System.Data.SqlClient.SqlConnection $ConnectionString
$sqlConnection.Open()
$sqlConnection.Close()

This will replicate the steps that are failing for you and hopefully produce a more detailed error message. When you run this you will be prompted to supply credentials. You should supply the SQL authentication credentials you have specified in the CognosConfigProperties.xml file.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

View solution in original post

1 Reply
ChrisG
Community Manager Community Manager
Community Manager

Are you looking to have Cognos use Windows Authentication or SQL Authentication to authenticate to the database?

If you are seeking to use Windows Authentication, this message likely indicates that you a username and/or password configured in the ContentStoreDatabaseUsername and ContentStoreDatabasePassword settings in your CognosConfigProperties.xml file. These settings should be blank if you intend to use Windows Authentication.

If you are seeing to use SQL Authentication, this message indicates a connecting using the credentials configured in the CognosConfigProperties.xml file could not be completed. Try copying and pasting the following commands (replacing "ServerName" and "ContentStore" with your actual server and database names respectively) into your PowerShell window:

$c = Get-Credential

$ConnectionString = "Server=ServerName;Database=ContentStore;User ID=$($c.UserName);Password=$($c.GetNetworkCredential().Password);"

$sqlConnection = New-Object System.Data.SqlClient.SqlConnection $ConnectionString
$sqlConnection.Open()
$sqlConnection.Close()

This will replicate the steps that are failing for you and hopefully produce a more detailed error message. When you run this you will be prompted to supply credentials. You should supply the SQL authentication credentials you have specified in the CognosConfigProperties.xml file.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

View solution in original post