Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issues reliably detecting machine name with web extension?

We hear feedback about intermittent issues detecting machine names but have not been able to investigate why.   I am curious if anyone else sees this as well and has any suggestions? 

We are using the web extension as the primary method for 'computer discovery'.    There is not a secondary method that will work for us.  

Our helpdesk is getting many calls per week for this.    Closing edge and re-opening seems to help most of the time.   

When I check the user log on the web server it looks like the server determined the web extension was not going to provide the machine name in < 1 second even though we have the timeout set to 5 seconds.  It moves on to a secondary method but we know/expect those to fail.   I can't tell if the 5 seconds timeout config is really being leveraged?  



(5) Replies

I've not personally ever changed (or needed to change) that timeout setting, but Flexera Support should be able to look into that more closely if you open a case. One thing to check if you're able to reproduce it would be to hit F12 in the browser and see if there are any errors listed in the Console related to the extension.  Could it also be in some cases that a user has disabled the extension?

Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".

In case anyone finds this post someday, we also bumped up the value of the WebExtensionTimeoutInMilliSecs property, in the WD_AppSettings table of the SelfService DB, and this has resulted in less calls to our helpdesk.   

Having the server wait just a little longer for the end user device to respond with the machine name from the web extensions seems to be helping, but it has not eliminated calls altogether. 

There are still some scenarios where users reach out to our helpdesk that we just don't understand the root cause of,  where the timeout value does not seem to matter, but closing Edge and re-opening does result in the machine name being detected.     Unfortunately we have not found this to be  reproducible.  

By Level 12 Flexeran
Level 12 Flexeran

Given the intermittent nature of the issue, I'm having a tough time suggesting a meaningful course of action. What do you have the WebExtensionTimeoutInMilliSecs set to? Have you tried increasing the "WebExtensions Computer discovery timeout (in seconds)" to a larger number. The two timeout settings are applied in different locations. 

The one think that seems to cause issues is IE compatibility mode, even if the App Broker site is flagged as MSEdge mode in the site list xml file. I don't know if it has something to do with switching between an IE mode session, and then to MSEdge mode, but typically closing the browser and reopening resolves the issue. 

Thanks Charles -

Yes we increased the "WebExtensions Computer discovery timeout (in seconds)" value and that was what made us start asking questions.  We didn't see a new 5 second pause in the user session log after we updated that value to the max option of 5.   We still saw a line in the log that the site was trying to use Web Extensions to discover the machine name, and then during the same second the log indicated it could not detect the machine name.

We bumped the "WebExtensionTimeoutInMilliSecs"  to 20 seconds.   We do see in some User logs that the process sometimes needs that full duration to receive and process the machine name.   It is usually quick, but can take some time.  

Thanks for the info about Edge.   We do still have a couple internal sites that Edge opens in IE mode and I did some quick tests.   I was not able to repro any issues but will try again, thanks.  

We had the issue a month or so ago.  Chrome worked 100% of the time and Edge was spotty.  We found that the registry settings weren't updated for Edge so we added registry keys to our web extension package and it resolved the issue.

Check the following keys:

Edge ( This one was missing and adding it resolved the issue)



C:\Program Files (x86)\Flexera\App Portal WebExtensions\Chromium\com.flexera.appportal.client.chromium.json





C:\Program Files (x86)\Flexera\App Portal WebExtensions\Chrome\com.flexera.appportal.client.echo.json











Top Kudoed Authors